Issue with Slicer extension

Hey,

Whenever I use the slicer extension and try to export the file to a DXF I get an error message. I can export to PNG no problem but when I try exporting to DXF only the first piece that is sliced works and then the error message appears.

Just wondering if anyone has had this issue? Or knows a way around it?

Here’s the file that I’m working on and the error message. NewWall1.skp (5.2 MB)

Cheers!

@eneroth3 might be able to comment here

1 Like

I’m not sure if this is the same Slicer extension. Mine slices a model once at a Section Plane and attempts to keep solids solid, named after the native Create Group from Slice command. I suspect this question is related to an extension slicing a model numerous times, similarly to the command in Rhino, and offers to export the slices in various formats.

1 Like

I see from your SKP that it’s referring to my Slicer toolset, then it begs the question why didn’t you post this in its main thread at SketchUcation ?
http://sketchucation.com/forums/viewtopic.php?p=374969#p374969
https://sketchucation.com/pluginstore?pln=TIG_Slicer
https://sketchucation.com/plugin/781-tig_slicer
There are ten pages of posts in its main thread…
Perhaps there’s a clue in one of those ?

A typical omission by users is NOT having installed the TXT ttf font that is supplied in a separate ZIP, and this can cause DXF export to fail… It is clearly explained in the usage documents.
A simple test is to NOT include a text-label and see if it exports OK [before slicing]…
With the TXT font missing on a MAC it always fails during Slicing, but on a PC Arial font gets substituted on the slice - but the failure might arrive with the DXF - most ttfs are very segmented - that’s why TXT is supplied to avoid this very problem !

You haven’t given us much useful information, but with more we might try to help you…

A few further observations… after repeating the Slicing from scratch on your SKP…
My slices include TXT font text-labels - yours seem to be in Arial, suggesting the correct font isn’t properly installed ??
Also you ‘wall’ is very finely faceted this can produce tiny geometry when intersected, which then causes later issues. My first and last slice have tiny bits of geometry dross floating about, as a result they are not ‘solid’, but manually editing those so they both report as solid in the Entity Info - after temporarily deleting the text-label - fixes that and the export then makes perfect DXFs…
Another weirdness… why have you smoothed the edges of the various component instance slices ?
This might cause issues with the DXF export and the more faceted Arial text-label gets corrupted ?
It’s not necessary to ‘smooth’ for the DXF - indeed it is counterproductive ?

So to recap… ensure you have the TXT font properly installed - it’s in a ZIP file in the Slicer’s folder, or you can get it separately here http://sketchucation.com/forums/download/file.php?id=81087
Check the fineness of the faceting on the wall - it’s creating tiny bits of geometry when intersected…
Try without text-labels to see if that helps…

2 Likes

My apologies, I started using SketchUp a couple weeks ago still familiarising myself with the program and using the forums.

Thank you greatly! I downloaded the proper TXT font and was able to successfully export the DXFs. I’m using these to place in another program to send and cut out in a CNC.

As for the strange issues with my wall, I created it by watching tutorials. Still wrapping my head around it, have a lot to learn.

Thanks again, I’ve been rushing to complete a project. Appreciate your help and for creating the slicer extension.

Glad you got it to work…

It’s not just Slicer that will have problems with overly fine meshes.
Any tool that uses intersect, solid-tools, followme etc can fail.
SketchUp has an inbuilt tolerance of 1/1000" - this is usually fine for most work relating to buildings.
But if you do an operation like a ‘subtraction’ and this would result in a tiny edge where the start/end points are within 1/1000" then SketchUp assumes the points are coincident and doesn’t make that edge, and of course the related face can’t be created either.
This leaves a ‘hole’ in the result, causing it to no longer be a manifold solid, and perhaps then compromising subsequent processes - including exports.
So very fine meshes with tiny geometry are best avoided.
One work around is to temporarily scale up the object, do the changes and then scale down - the tiny parts can exists but they can’t be directly created.
Unfortunately this could be fraught with Slicer - e.g. scale up x100 and adjust all of the dims in the dialog to match, do the process, but them you need to scale the slices down too - so lots of steps to get a good result…

In your ‘wall’ SKP the sliced mesh contains some edges that are only ~5mm long, which on its own shouldn’t cause issues, but because the mesh is then triangulated any new slices can snip through the point of a triangle, leaving some tiny edges which don’t reform and can cause issues…
You seem to have sidestepped it…

Using the TXT font for the text-labels also avoids potential pitfalls as it’s mainly straight lines, whereas the fall-back font Arial has curves etc which produce tiny edges, which can fail in the DXF export…

1 Like

Thank you!

Ok, yeah interesting. I have read that before that scaling up the object making changes and scaling down can work.

That is another thing I was wondering about. I created another object and used slicer successfully however, it is made up of sharp edges and I’m aiming to have smooth curves. I think it has something to do with how I created the object initially and not to do with slicer itself. Here are some photos of the sharp edges I’m referring to and the file.

Do you know how I can create the object but instead with smooth edges? Is that possible?

Thanks again mate.



ParametricPatterns2020c.skp (5.0 MB)

It’s a balance between segments in the curve and SketchUp’s tolerances.
Having small edges or tiny triangular facets in a surface will at some point fall foul of the missing geometry issue.
Scaling up and doing the processing will often avoid it, but there are limits…
The “Dave Method” might help ?
But you need to consider setting the larger dimensions and the out put for tools like Slicer