DXF 3D Export issues


#1

I’m having several issues with SU 2018 DXF export. It doesn’t matter which DXF version. I have checked all the options. Here is a very simple skp file. I included the arc inference so we all know that it is an arc and that the proper geometry exists. Also be aware that the Label 3 is made up of 2 arcs. I have added construction points for the small circles.

I then export the skp as a DXF and then either look at it from another CAD system or import it back into Sketchup. Either way the drawing now looks like this.

Additionally the DXF now is composed of Blocks which is not compatible for the CAM software we want to use.

test_part.skp (29.7 KB)


#2

I am not seeing your issue when I export.

Can you share the dxf and let us know what dxf options you exported with?

CD


#3

I exported to DWG and DXF and viewed the file in AutoCad 2017. Both looked OK, with no extraneous circles added. Reimporting into SU didn’t change things either.
That the objects become Blocks is because in your model they are Groups. There is no such object as a Group in the same sense as in SketchUp in AutoCad so the exporter makes them into blocks. You should probably explode everything before exporting to avoid the components. This is what I did before exporting the third file.
The anomalies might be caused by the “another CAD system” you are using.
test_part.dwg (42.4 KB)
test_part2.dxf (126.2 KB)
test_part3.dxf (126.3 KB)


#4

As I said at the beginning of the post. “I have checked all the options.” In this case it is Release 14

test14.dxf (126.4 KB)


#5

The other CAD system was to determine if the problem was during export or import. The other CAD system only read the file and did not modify it in any way.


#6

Which version of SketchUp? Are you using the native exporter or an extension? Those I did was with the native exporter in SketchUp Pro 2018.


#7

SU 2018 internal DXF Export Release 14 all options checked.

I exploded the skp file and that certainly helped. The Circle is no longer there and the 3 is oriented correctly. However - one of the arcs making up the 3 no longer has arc info.

The end of the arc is now here (after re import)

Where as the other CAD system displays 2 perfect arcs.

My guess is that I was OK when I had fewer segments (8) for the 2 arc segments making up the 3. Because we can’t control that during a DXF import the segments got too close together and there fore SketchUp now treats it as segments - not an ARC. If the model was 10 times larger then it may have worked.


#8

I used groups because I need layer names to export with the DXF.

I’ve added a pocket for CNC routing. This pocket has an edge that falls on an edge of another part.

Exploding the group causes the geometry to move from Layer0 to the layer that the group was in. Secondly - overlapping geometry changes adding extra points at the intersection point. Also geometry that didn’t share a common edge now has the edge belonging the layer of the last group that was exploded.

It appears that the DXF export can’t do what is required because:

  1. Groups create Blocks
  2. Exploded Groups alters geometry.

#9

This topic was automatically closed 183 days after the last reply. New replies are no longer allowed.