Export to DXF in 2020 wont work with SketchUp 3DText tool

I am having problems exporting previous sketchup drawings that include text (created by sketchup text tool).

I can open the drawing, I can export the drawing but when the DXF file is opened on our SwiftCut CNC plasma machine the text is missing large amounts of lines and detail.

Lines that are drawn with the pencil, square tool and circle all transfer perfectly. (When drawn in 2020)
When files using older versions are used some lines also do not transfer cleanly.

Any solutions.

Which text are you referring to? 3D Text or screen or label text?

Can you upload a .skp file that has this problem?

Have you adjusted the export options, Options button on the export dialog,?

We use sketch up to create 2D files to export to our CNC Plasma machine to create student Projects. We use the 3D text minus the extruding option and place the text in the surface of the drawn shape. We then explode the text and delete the internal space.

The machine will then cut the shape and the text
Carlton Logo.skp (293.0 KB)

When the old file is opened in 2020 and exported the text and some of the lines do not transfer over it reads on the machine as line segments missing.

Yes have tried to change the export type to other version and still no change

Try this one.
BoxCarlton Logo.skp (286.5 KB)

That Worked Perfectly, What is different about the file?

I appreciate the help but would like to know if I can replicate this on my end

It’s actually very simple, it wasn’t flat.
I used vertex tools to make it planar, but any flattening extension should do it.
Or simply extrude it through a face and intersect it and the new one on the single face should be flat.

Thats interesting as it was drawn on a 2D plane and in all previous versions of sketch up it was seen as flat.

No Changes were made when it was opened in 2020.

Maybe evidence of them correcting the sloppy tolerance that SU tends to allow. Older versions let it through.

Something to note, be careful with exploding lettering, and this could be the cause of the tiny error in the face, 3d text is placed just off the face it is glued to to avoid z-fighting. So it’s best to extrude it though and intersect it to get clean edges.

Thanks this has been a big help

1 Like

Exporting the coordinates of all vertices in the OP’s original file shows it is flat.
But there’s a mixture of layers assigned to the raw geometry.

Exported from the file opened in SU2020
Carlton Logo_verts.txt (30.6 KB)

I was aware of the different layers, but that is a technique used effectively with tool paths.

Working with the the OP’s file (unmodified) …

• Setting the Export Options to export only edges from SU 2020 to a 3D DXF R12 resulted in missing geometry in the DXF

• Oddly, it worked fine when I deleted all the faces in the OP’s SKP file and then exported a 3D DXF R12. I made no other modifications to the SKP file.

There are many ways to skin cats. I tried one version where I used curvizard to weld the edges. This made sketchup want to fix the model, if I allowed that then it only exported the b of club and some other random parts.

The flattened option that I posted was the first one of 11 versions I had tried that appeared to export correctly.
I didn’t bother mentioning the layers or the short extra edges or the edge gaps, all of which I corrected and found they didn’t fix the export.
I posted number 12 once I had double checked that it worked.
Feel free to experiment to your hearts content.

Perhaps (like any word for a task,) there are better known regional synonyms.
I have since added the tag “engraving” as it was already defined and used several times.


Debossed / Debossing is the opposite of Embossed / Embossing.


I am respectfully answering your question in good faith … please also be respectful.

I’ve just had a similar issue in exporting from SU2020 to Fusion 360 for CAM, which seems to have been solved by selecting and exploding the geometry of the text - it seems like the welded text curves didn’t merge with the surface they were sitting on by default.