3D model export not working in trial version (mac)

Hi everyone,

I’m using SketchUp Pro 2017 trial and I have a problem with export. Since yesterday I’m trying to save one file to DXF folder in my dropbox.

File - Export - 3D Model - DXF folder (located in dropbox)

Instead of saving it, an error showing up:
Untitled.pdf (277.5 KB)

I tried everything that people was advising but nothing works. I also emailed support team to use community forum.
I feel like I’m going nowhere.

I will appreciate help in this matter.

Can you share the model itself? Drag it from Finder to the window where you post, or use the Upload icon (7th from left above where you type your post).

does saving the same file to the desktop work?

does opening the “Report…” denotes some more information e.g. regarding a faulty library or script etc.?

I tried saving to the desktop or any other folder but the same error appears.
I’ll check what the report says, but should I look for any specifics?

not for the ‘spaghetti’ code (hex) but file names denoted.

I have tried to do a 3D DXF of a basic square in a new file and it still crashes straight away. It needs to be a 3D DXF so that any holes are exported as true curves for laser cutting.

Test file.skp (70.6 KB)

I see you are trying to run SU 2017 on OS X Yosemite. I don’t think it is supported on that platform, and that may be the cause of your problem.

Running SU 2017 latest on Sierra here, I have no problem with exporting your test file.

Can you upgrade the OS on your hardware? At least to El Capitan, if not Sierra? Otherwise, try running an older version of SU.

See:
https://help.sketchup.com/en/article/36208

It says SU2017 is supported for 10.10+ Yosemite.

Wouldn’t hurt to upgrade the OS anyway.

More likely the problem is related to graphics drivers.

Thanks for the correction, @DaveR - I was incorrectly relying on memory, and should have looked it up.

I hadn’t thought of graphics drivers in connection with export, but limitations in the drivers seem to be at the heart of many of the problems that SU2017 users have had with the revised and upgraded graphics pipeline in v2017.

graphics driver shouldn’t hurt the export of vector formats as DXF/DWG but typically raster formats only.

Thank you guys!

Ok, so I have new upgrade - Sierra. I tried to use SketchUp to check if it works but my trial expired.
I installed Sketchup Pro again, however the same expiry information appears.

Untitled1.pdf (176.3 KB)

If you’ve used the SketchUp trial for 30 days, the trial period is over. You wiill need to purchase a license to continue with the pro features. You might try contacting customer support directly and see if they would extend your trial period. Go to SketchUp.com to contact them.

I got the trial yesterday. It should not expire that quickly.
Is it because of the upgrade?

It probably has something to do with it. You’ll still need to contact Customer Support. They should be able to fix it for you.

Thanks

So my sketchup is working, thanks to Lisanne from support team, however the report still shows.

I’ll be grateful for your help.

still:

See attached report
SketchUp Report.pdf (168.9 KB)

The crash report indicates an uncaught exception while the exporter was trying to save fonts used by dimensions. If I recall correctly, one of the problems addressed during the adaptation of SketchUp to newer macOS releases involved changes in how the os handles fonts. Perhaps you are seeing a regression of that? What font are you using for dimensions?