Export to DXF fails

A month ago I learned how to export 2D files from Sketchup and did so successfully with at least one file. Now that I really need to do it, I’m getting the following message:
“The export failed or was canceled.”

This is happening in any of the Sketchup files I open, including the one I was able to export before, as well as a test file with a simple rectangle.

I’ve restarted my computer, but it didn’t help.

Any other ideas?

Maybe you could share a .skp file that we could look at it see if it’s something with the model that is causing the problem?

Here is the simplest one that failed.test.skp (115.1 KB)

This is what I get when I export your file as as .dxf. Does it look right to you? It does for me in DoubleCAD XT.
test (1).dxf (6.7 KB)

Did you install SketchUp correctly? That is, did you right click on the downloaded installer and choose run as administrator?

You say this worked for you previously but doesn’t now. Your profile says you are using SketchUp 2019 and an integrated GPU. If that is true, what has changed on your computer since it worked? SketchUp 2019 didn’t. So then what? A Windows update with a broken graphics driver, maybe. That’s not uncommon.

Yes, that’s right. It’s just a simple rectangle. But when I try to export it I get:
image

See the edit to my previous reply.

Where are you trying to save the file? Locally or to the cloud?

I am attempting to save the file locally.

I don’t recall any significant changes to my computer in the past month, but it’s possible there was an update since those are automatically installed. I did travel to Canada and work from there and then came back, but not sure how that would have caused any changes. It’s been a long time since I originally installed Sketchup and I use it quite a bit, so I would think that if I had installed it wrong there would be other signs.

Do you think it is worth uninstalling and reinstalling?

You might check that you are using the latest maintenance version of your version of SketchUp.

Uninstalling and reinstalling doesn’t necessarily fix it.

I seem to remember that something like this has been happening if the preferences file(s) have got corrupted. @colin might be able to tell where to find them and what to do to restore them.

I’ve now installed Sketchup 2021 in case that fixed it, but it has the same problem.

1 Like

Did you install it by right clicking on the installer and selecting run as administrator?

I exported your file using SketchUp 2021 and no problems.

What is the path and name of the folder into which you are trying to save it?

Yes, I ran it as administrator.

I’ve tried saving to my desktop, to Documents, and to the specific folder locally where I normally save files, including the previous DXF export I was able to do a month ago. None of these worked.

1 Like