"Disappearing" exported DXF files

Teaching myself cad and cam for a home-built cnc router. Things were all well until I updated to version 1903 of Windows 10. Now, when I save an exported 2-d graphic as a dxf file I get"export audit ok etc" but that file is nowhere on my laptop, never mind the folder I told where to save. I’ve used all the options in the drop-down tab - R10,R13, 2000, 2004 etc - it worked previously with 2004. I normally import the dxf into inkscape where I clean it up etc, save as svg and import it into cam (Carbide 3D at the moment until I can get Fusion 360) where I generate gcode and then cut with cncjs. Hope I’m on the right topic/category and that there may be someone out there with advice.
Cheers.

If you can share the problem skp file, we can test whether we can reproduce the issue and perhaps diagnose what is the cause.

Also, what is the path setting for …
Window > Preferences > Files > Export models:

Sorry mate for the long and not too clear explanation/question. I’m exporting a 2-D graphic from SU and saving it as a dxf file that I can later import into Inkscape. When I look for the file it isn’t in the specified folder or anywhere else on the drives.

The setting is: D:\Documents\PROJECTS\

Try @gkernan’s exporter plugin …

What happens if you export the file to the desktop of the C drive, does it show up?

What drive is your SketchUp program installed on?

Of course sharing the file would help others narrow things down for you…

Hi Ian - tried it and it doesn’t show up on the desktop. I thought that I shared the file with slbaumgartner earlier, but here it is again. 21 KEY 2.skp (40.3 KB) .

I don’t see anything wrong with the file that would prevent a DXF from being created. It worked for me.

You say it quit working after a Windows update. You could try rolling Windows back to before the update. You might also try reinstalling SketchUp making sure you right click on the installer and choose Run as administrator followed by Repair.

It works ok for me too. I agree with Dave that if it did work before, it would seem the windows update might have done something.

The strange thing is I also ran into the exact same problem as yours where the dxf simply did not appear after writing. But in my case it were using a certain version of the above mentioned “Simple DXF” plugin, not the native exporter you are using. I never figured it out but resorted to using an earlier version, very strange.

Hi Dave - yes I agree wrt the Windows update. Apparently my “System Properties- Environmental Variables - System Variables -Path” was affected somehow by either the update or a later installation of Python. I have already done the Admin and Repair bit with no change. I’ll see if I can find someone here to come and have a look at my Windows System Properties etc. I’m now sure that the problem is not with SU. Thanks for the feedback though.
Regards,
Joe

1 Like

Good luck. Hopefully you can get some useful information from whomever it is that deals with it and you can report what the fix was. Might help someone else sort out their problems.

OK, problem solved. It seems that when I installed Python either that installation or my old fingers (unlikely) changed the setting of my System User Variables to, eg : C;\Users*Home*\OneDrive etc whereas it should have remained on C:\Users*Main*\etc, etc.
Anyway, dxf exports are going to where they should be again.
Regards,
Joe

2 Likes