Is there a way to make the scale of imported models same with the current model

I did some interior modeling and saved the models out now when I open my project(house) and then import my models their huge but sometimes their small🤷🏾‍♂️ is their a way to make the scale the same without using the scale tool

Use the Tape Measure tool to resize them before you bring them into your project model.

Why are they different sizes in the first place? They should have all be modeled with real world dimensions so they should all have the same “scale”.

2 Likes

That method is going to be a challenge I did a lot of models :pensive: best to start early then​:frowning: Eve noticed sketchup misbehaves sometimes and messes up with the scale when modeling at least on my side

I’ve never seen that happen but I’ve only be using Sketchup for about 20 years.

1 Like

Seriously let me send you a picture

Share your SketchUp files. Pictures won’t help.

I’m sure it can be traced to soething you did in your modeling process.

I can’t seem to upload the files saying not supported🤷🏾‍♂️

What kind of files are you trying to upload? SketchUp files (extension .skp) are most definitely supported.

test1.skp (70.0 KB)
test2.skp (67.9 KB)
both of these models are 2meters high

Yes they are but there’s nothing different about their scales when you import one into the other.

Here’s your test2 file with dimensions added.

And when I import it into your test1 file it’s still exactly the same dimensions.

No change of scale.

It sounds to me as if you should spend some time going through the tutorials at learn.sketchup.com

2 Likes

Then that proves it🙄 cause I wanted a model like test1 but sketchup showed me a size like test 2 with the changing scale I messed up the size of the models because I thought they were small so I increased them now I have to scale them back to the desired size☹️I get it now cheers🥂

Yes. It proves that you drew the two things at different dimensions. You can certainly resize the large one with the Push/Pull tool if you don’t want to use the Scale tool. Or you could do it with the Move tool. In any case, SketchUp didn’t do anything incorrecly. This is all on you.

1 Like

Note that SketchUp has different model templates for different model unit settings. Modelling unit can also be changed any time in the Model Info dialog.

A very common beginner error is to start a model in a template using meters but create a model thinking that the input unit is millimeters, resulting in rooms with 3 kilometers high walls.

1 Like