Is it possible to turn off Section Fill in SketchUp Free?


#1

Until approximately a week ago there was apparently no section fill in the version of SketchUp I was using. I was using section cuts frequently both for viewing the models I was working on and for accessing inside the models to continue adding detail. I don’t know whether there was an update to the application or I inadvertently made some setting change, but suddenly every section cut is filled. I would be happy with this except that the fill sometimes “leaks” out of the interstitial spaces where it belongs and fills whole rooms or even stories of the building. In models where this is happening it completely impedes viewing the model in section or plan view and makes it impossible to enter through the section cut. I’m sure the leaks are evidence of a mistake on my part (e.g. failure to close the interstitial space) but with this happening it’s hard to even get in to discover where the error is. I’ve tried for a couple of days to find a way to turn off the fill but so far without success. Please help!


#2

Are you using SU Free or SU Shop?
If you are seeing section fill then you may have chosen a style with section fill turned on. In SU Free you can’t edit styles but you can in SU Shop, section fill is one of the options you can turn on and off.
If you are using SU Free try changing to a different style, one that may have section fill turned off.
It may also be that having been recently added by the team it is now turned on by default and they haven’t yet given the free users a way to turn it off. This sort of thing often happens when the implement changes on the fly.


#3

It looks like they have set the fill to show by default in all styles. with the exception of the default templates. So if you have changed a style you can’t change back at the moment to one without fill.
But, if you copy your model, then open a new one from the default templates and paste in place, you should have no fill in your section cuts.

Edit: No, forget that, all that does is cut the model and only paste the geometry visible without the section plane and the rest of the geometry.

@jody do you know if section fill has been added without the option to turn it off deliberately in free or as an oversight/option to come?


#4

Hi everyone: section cut fills can be disabled or customized by color with Style Editing, which is available with a Shop subscription.

So, yes: opening older model templates with style settings that are already configured is one way to work around this.

But, we didn’t change anything about this functionality in the last few weeks and @carolyns, I am curious what you mean about the section fill ‘leaking.’ Would you be willing to share a screenshot of what you are seeing?

Mark


#5

Box,
Thanks so much for getting back so quickly! Your answers are very helpful. Unfortunately so far I’m just using SU Free so I don’t have the SU Shop option of turning off Section Fill. I did try the approach of opening one of my models with the fill problem, deleting all section cuts, copying the whole model and pasting it into a new model and that did seem to restore it to having no section fill.


#6

@Mark open any SU Free template, create a cube and use a section plane to create a cut. You should see inside.
Now change to any other style, the section will fill in. Show us how to get back to an unfilled state without using SU Shop which has the ability to edit styles.


#7

Hi Mark,
Thanks for addressing this question. Re this functionality not changing in the last few weeks, perhaps I just ran into the problem recently because I only recently started experimenting with styles on these models. (I had experimented previously on much simpler models without a problem.) I’ll see if I can come up with a screenshot to share.
Carolyn


#8

Hmm, new at this sharing screenshots. Does this work?


#9


#10

Thanks for clarifying the issue, Box. I agree this is a bug. I’m not quite sure (yet) which default styles shouldn’t have a section fill associated with them, but I do agree that you should have the option in a few styles to use the section tool as a visibility aide (as opposed to a drawing production tool).

I’ll update this thread when we have a plan on this.


#11

Hi Carolyns,

I can’t quite tell what is going on from this image, but I have an idea…

Looking at both images, it looks possible that you may have a problem with your wall geometry (the inner part of the wall ). That is, it’s possible you just have one entire face and that there is a hole in your wall geometry. In the sectioned plan, it looks like the section cut and fill are working properly on half the plan, but not all of it. To me,. that indicates a problem with your internal wall geometry in that one part of the house.

You have the same problem in the elevation; there, I’d take a closer look at the bottom of the elevation to see if wall faces are being created with your geometry.

Thanks for posting; I hope others will chime in with ideas too!

Mark


#12

Thanks Mark. I’m sure you’re right about a problem with my wall geometry. Now that I’m able to access the models again (using the copy/paste-to-new-default-template workaround) I’m able to get in to search for my mistakes. :relieved: