Invalid ResBuf when importing DWG

dwg
import

#1

I am trying to import a dwg into sketchup. When I do so, I receive an error saying “Error opening AutoCAD import file: Invalid Res Buf. This does not appear to be a valid AutoCAD DWG or DXF File or the file is write protected.”

The file is not write protected. I have tried saving the file as a 2000 autocad, same thing. tried exploding the dwg, same thing. Tried deleting all unneeded information, same thing. Any way around this?


#2

Is this with SketchUp Pro 2016 ?


SketchUp Users Guide: Getting Started in SketchUp


#3

Sorry, yes it is


#4

This sounds familiar from something I’ve experienced. Have you tried quitting sketchup and starting it again?


#5

Tried that, and also tried renaming the dwg, no luck


#6

Sure I had this and it fixed quite easily, I’m not on same version as you though. It wasn’t the dwg in my case I had lots and none would work.

Have you been successful importing before, any dwg,dxf?

(Edit) Have you restarted computer?


#7

Any change if import options changed ?

You know, someone will come along eventually, and ask if the problem file can be posted.


#8

No sorry , I’ve tried to replicate the error with no luck,

@DanRathbun idea of posting upon request is good, see if someone with 2016 can get it to import.


#9

Does this happen only with one file, and others import OK? if so, can you upload the file that has this problem?

Are you running the latest maintenance release of SketchUp 2016?

Anssi