Invalid character preventing install

I’ve been trying to reinstall sketchup 17 make version on my win 10 desktop. I keep getting the error “the folder path ‘Program Files’ contains an invalid character”

This link hints at a similar problem but being 7 years old, I’m not sure how to translate it to my os:

I’ve tried getting the most current version (sketchupmake-2017-2-2555-90782-en-x64) but it doesn’t seem to make a difference. My internet connection is not reliable or bandfat enough to be happy with the web based version. (Apparently too cheap for the pro version also)

The installer should be asking where you want the files installed. You can edit the path.The message is telling you there is a character in the path that does not belong. The path should look like this
" C:\Program Files " (without the quotes)

I’ve tried moving the install file to several folders to run it. I’m unable to choose my own path to install it. I never get that option. It’s always program files (that’s where sketchup used to be before I uninstalled it, thinking that was the problem.)

Today I tried a fresh clean download so it was in the d: downloads folder. Still wants to try the ‘program files’ folder. I’ve usually done the ‘run as admin’ option to install.

Is there somewhere I could download and go back to sketchup 16?

Thanks for your help.

SketchUp needs to install in Program Files and normally on the C: drive.

What exactly is the path to Program Files on your computer?

I’ve installed everything in d: program files on my computer. C: is a ssd and I’ve tried to keep it uncluttered. 3rd drive is a nas drive for backup use. D drive is a hybrid type. And I’ve installed all my working files on it. Downloads, documents, programs, … Everything but windows and pirated music.

Good thoughts. I’m not for certain I’ve ever moved the installer to c or f to install there. Worth a shot later.

Any ideas why the installer doesn’t let me choose a new destination?

I wasn’t suggesting that you move the installer to a different drive.

What drive is the operating system installed on?

Why would you make a non-standard setup for installing applications? Do you enjoy chasing problems? Windows would normally be installed on C: and the Program files would be on the same drive.

I have a 256gb ssd for c: and windows(os) is in it and I try to put nothing else in order to keep it working fast. It hasn’t been problematic until sketchup needed to be reinstalled. If that’s the cause…

I didn’t want to spend top dollar for a large capacity ssd to put everything on. It’s easy enough to change the drive letter when installing stuff. … normally…

As I said, the Program Files directory is normally on the same drive as the operating system. Separating them is likely to cause you problems and not just with SketchUp.

Use your other drives for storage and leave your C: drive for the OS and Program Files.

Or maybe, since SketchUp is just a hobby thing for you, you could continue to monkey around with it.

I appreciate that guess. But I built this setup 4 years ago and it still moves along pretty fair and hasn’t had problems until this week.

So I’m not quick to agree that there’ll be a bunch more with other programs or applications or whatever.

What you say makes sense in a general principle way, but these years of it not being a problem, even with sketchup, gives me pause.

1 Like

I guess you are going to resist what is known to work so I’ll just wish you good luck.

Thanks for the thoughts, I’m out chasing cows this afternoon and when I get back to my computer, I’d love to try installing it in c: program files.

Just got back in. I moved the installer file to c: and got the same error. Tried both the program files folder and the program files x86 folder. Absolutely no difference in the error message (To my untrained eye).

Thank you for the well meant efforts but I’m still open to suggestions.

Can you show the full path that the installer is going to use? It ought to be exactly this:

C:\Program Files\SketchUp\SketchUp 2017\

1 Like

I never get an option to choose the path that the installer is targeting.

If anyone else has tried this installer and had the option to choose destination path, I’d love to hear.

Do you see this screen at some point?

No. I never see that screen when trying to install the above quoted installer file. Or any of the different user input type screens that would allow me to choose a destination folder

And it looks like the same general version – Make 2017 64 bit…