2017 looks for old, non-existing drive and won't load on win 10 machine

installation

#1

HD crashed, replaced it with a new one and restored all files. Previous drive was “F:” and new one is “D:” “F:” no longer exists. Now when I load Sketchup, it opens a dialog with title=“Insert dis” and msg=“Please insert a disk into USB Drive (F:).”

Neither can I uninstall it (using Win10 uninstall), and instead get a msg="sketchup2017’ is not a valid short file name’

Tried to label a USB F, but that option is not available on Win10 Disk Manager.

Totally stuck.


#2

You need to reinstall it. Download the installer file and right click on it and choose ‘Run as Administrator’
Choose ‘repair’ when prompted.
Typically, it want’s to install on the (standard) C: drive and in my experience, this is the best place to install (Had some issues when installed on D: , not sure why, but I am an old-fashioned guy and I like to preserve C: drive for executables and other for data.)


#3

Wow, thanks for the speedy advice! I’ve run as Admin the SketchUpMake-en-x64.exe from “C:/” (I’m ‘old-school’, too!), then it downloads/installs the Visual C++ libraries (which should already be present on my system, then opens the SketchUpMake 2017 installer splash screen and ‘computes’ the space requirements. That’s when I get the dialog that says “‘sketchup2017’ is not a valid short file name” and presents an “OK” button only, which when clicked, informs me that the wizard ended prematurely because of an error. At that point, all I can do is click the ‘Finish’ button and try again later, with the same results.

I’ve used this program for years, the only thing that’s changed is that I no longer have a drive D:


#4

were did you get it? it should be called “sketchupmake-2017-2-2555-90782-en-x64.exe”
if downloaded here:
https://www.sketchup.com/sketchup/2017/en/sketchupmake-2017-2-2555-90782-en-x64-exe

Make sure you have all permissions to write on that disk, and again, you should try to install on C:/
Disabling antivirus software temporarily might also help.
Also, did you rebooted after renaming the drive?


#5

OK, I ran the linked exe with all firewalls,AV disabled, got same results - could see no difference at all. I couldn’t rename the D: drive to F:, since F: was not an option in the Windows 10 Disk Management utility. I’m guessing that since I had already named the crashed drive F:, then somehow it reserved it somewhere deep in the system (registry?) and therefore doesn’t see it as an option. Could be quite difficult to locate and fix.