File not found or invalid (Appears to not be a Sketchup Model)

I’m running into issues with several of my Files. I’m able to save my files but, when I attempt to open it the next day, Sketch up keeps saying “File not found or invalid”. Is there a fix for this? I keep attempting to recreate 3-4 of the same file for it only to be lost the next day.

Hello, how do you open your files, from SketchUp or by double clicking on an skp file ?

I can open my files from SketchUp

So it works from SketchUp and not from desktop ?

Correct

Right click on a skp file and go to properties. You should have a “modify” button, click on it and relink to where your SketchUp.exe is. (sketchup may appear in the list of programs to open with. try that first. If it doesn’t fix it, go to the very bottom and pick “select a program on this PC” and reach for C> programs > sketchup > sketchup 2019 > sketchup.exe)

I tried that and it keeps saying “This doesn’t appear to be a SketchUp model”

can you upload one of the files you can’t open here ? (simply drag and drop, if not too heavy)

Edit : it seems you joined the forum recently and won’t have the right to attach files here. Send it over through wetransfer !

Ok, how am I supposed to send it to you on wetransfer?

go to wetransfer.com, upload the file and pick “get a link”, copy it and paste it here

https://we.tl/t-NkuNntPOen

Got it! here’s the link

I get the same error, wether I open it from sketchup or desktop.

Perhaps @colin will be able to help you out as he’s been faced to those errors recently… But I believe he would be sleeping for now !

Ok, thank you for your help! Hopefully @colin will be able to assist me with recovering my file

@colin, That file has no useful data, nothing but 168K of 1’s and no 0’s. Sorry.

Thank you Barry.

@schanelstarr in order to understand why your files get corrupted, maybe you could give more informations, such as :

  • do you have any other sketchup version installed
  • did you install sketchup 2019 recently - have you always had this problem or did it just appear ?
  • where do you save your files ? hard drive, removable device, local network… ? have you tried changing the saving location ?
  • you said earlier that you could open the files from sketchup but not from desktop. do you confirm ?

For most of these cases there is something there, and I can get at least the components out of the file. But then recently I had a case where the file was massive, except it was all 00. As a zip file it was tiny.

So, I knew to check for that this time. For this file it’s full of FF’s (that isn’t an acronym).

If schanelstarr has a workflow that continually makes the files be filled with 00 or FF, that would be worth studying.