Urgent file not found or invalid macos

I have a file I have been working on for quite some time, the last time I worked on it, it opened perfectly fine, but yesterday when I tried to open the file a window with “File not found or invalid” appeared. When I view the file it appears with the size (does not appear empty), but i cannot view a preview of the model on the preview window. I have tried importing it to a new file, changed the name and looked for the skb file but I cannot find it, it might have not saved. I have looked through other posts and I think the problem might have been that I saved it on an external hard drive, my hope is maybe there is a chance to save it with someones help, I now know to not save only on my external hardrive and verify the skb file is created correctly. Any help is appreciated. I’ll attach a link to download the file.

LINK: WeTransfer - Send Large Files & Share Photos Online - Up to 2GB Free

There are chunks of bad data in the file. The data was replaced with zeroes. I don’t see anything to recover from my end. Are you using a cracked version of SketchUp Pro? That might also have an impact.