"File not found or invalid" Help

Hi,

When I try to open my file I’ll see this pop-up “File not found or invalid”.
I use the newest version of Sketchup Pro on my Mac. The file is located on my computer (so not online).
The file is around 50 MB big.

I won’t see a solution in all the other topics. Please help me to recover this file. I was just finished so I am a bit disappointed that this problem occurred.

This is the file:

Thank you very much,
Brenda

I couldn’t open either of them. Maybe @colin could help?

I seem to have been able to rescue something. The two files look like the same model, but I included both of them.

1 Like

Hi Colin,
That sounds great! Thank you very much.

Do you know how the error was possible and how I can prevent it?
I’ve worked on the file in my online Dropbox storage. Is this possible why the error showed?

Thank you for letting me understand this issue.

Best wishes, Brenda

Dropbox, or saving to online file servers, is one of the things that could lead to problems. If the file server is backing up the file, or otherwise being read at exactly the same time that SketchUp is writing the file, could lead to issues with the file.

But, there are enough times where a file gets into this state when there wasn’t a remote file server involved, so there may be more than one cause for the issue.

In general, keep a copy of the files you are working on, and only open the copy if your main file gets corrupted.

Hi @Colin,
I have also have this problem, as my windows computer updated and nearly wiped all my work.
However I was able to recover my files, But when I try to open them, I get the message [“File not found or invalid"}

Could you help ?

Many Thanks Warwick Avenue proposed 3D.skp (7 MB)

I tried, but the file I got was about 1 MB, and didn’t seem to contain anything.

Hi, can you try this file? I think its 7.3MB.

Thanks again!

Warwick Avenue proposed 3D.skp (7 MB)

I have been able to determine the file is created with 18.0.16975 SU version, and get the thumbnail of it:
image

But further investigation confirms that at least the end of the file is corrupted. That is why SU reports:
Unexpected file format. :frowning:

I Hope colin will have more tools to recover…

Many thanks for trying @dezmo. Yeh Its an annoyance, I’m currently blaming Microsoft.
Fingers crossed for @Colin although, Im a bit doubtful at this moment!

Thanks

1 Like

The file I tried already was the same 7 MB file. When I said the file I got was 1 MB, I meant after trying to recover it. So, nothing much in the recovered version.

Darn shame! any suggestions?

Were you using components in your model. If you look through these sorts of threads you’ll see that generally the only thing that gets recovered is the components in the model.

It wasn’t my model unfortunately, but I think it was a combination of components and groups.
Currently working up a re-model, Ill make sure I have backup this time!
Thanks

1 Like

Hi @colin, I have that ‘file not found or invalid’ issue too…
could you help? file is on the cloud, I can see the thumbnail but opens blank. anyways I downloaded it that way and here is the link…


thanks in advance…

Did you notice that the file is 9 kb? It opened ok for me, but was naturally completely empty.

Did you upload a shortcut by mistake? How big is the file that you have?

Buenos días @colin , llevo solo tres semanas utilizando sketchup, soy nueva aquí.
Esta mañana al intentar abrir mi archivo me encontré con el mismo error “formato de archivo inesperado”. Yo tengo el archivo en mi ordenador, y ayer mientras trabajaba importé unos modelos de una versión anterior y no me dejaba guardar el archivo, dándome el siguiente error:
“La función de guardado automático tuvo un error debido a una ruta de archivo no válida (C:/Users/mjcon/AppData/Roaming/…/Local/SketchUp/SketchUp 2019/SketchUp/working/SKETCHUP/RecoveredFiles/modelo_1.skp) o a permisos no suficientes. Por favor arregla esto yendo a Preferencias de SketchUp > Archivos y especificando una ruta válida con acceso de escritura para ‘Modelos:’.”
La única solución que encontré fue eliminar esos componentes que había importado, y pareció que guardaba el archivo sin problema. Pero esta mañana no abre. Envío en el siguiente enlace:

Os agradezco cualquier ayuda, de momento voy a repetir todo el trabajo de ayer

Thank you @colin for taking your time.
I did not upload a shortcut, but I had to download it after the file is already corrupted. No backups in hard disk :frowning:
The file is 3.7mb on the cloud. Screenshot 2020-09-12 114742
do you think can we at least save the components?

If you saved in the cloud, why not go back a few versions? There are 87 saves done, they all should be in the revision history.

all have same issue :confused: