File Paths "Invalid"


#1

I reinstalled SketchUp 2018 on my laptop, Windows 10. I get an error “File Location Paths Invalid”. In Preferences, all the file paths are RED except for Templates. They are apparently invalid. I do not know what they should be. Should not this be taken care of automatically?


#2

You need to choose appropriate folder-paths for the various defaults in the Preferences > File Locations dialog:
‘Templates’ has an unchangeable path, but the others are your choice…

The others need to be set up [once], e.g.
C:\Users\USERNAME\AppData\Roaming\SketchUp\SketchUp 2018\SketchUp\Components\

As well as the default ‘saving’ folders, you might want to set up the other paths, like Exports:
C:\Users\USERNAME\Documents\


#3

It does not make sense to me that I need to set up these paths- they are standard locations set by SketchUp. OK if I want to change them, but I have no need to.

The ones in RED are perhaps standard, but ‘invalid’. All of them begin either:
C:\Users\chris\AppData\Roaming\ or C:\Users\chris\Documents
Why are these invalid?
And the program doesn’t allow me to edit the path, only browse. So, for instance, if all I want to change is my user name, I have to browse to the new location, but lose the rest of the string.

Anyway, I reset them all to Desktop.

Then I try to import ‘preferences.dat’ from my PC and it resets all the file paths to RED and invalid.
All I want to do is import my Shortcuts.

The Preferences import/export should be a simple one-click exercise.


#4

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.