SU 2020 pro preferred template File Location Path error

Migrated SketchUp Pro 2020 to new Windows 10 PC. Upon startup, received error message indicating that one or more of my preferred File Location Paths are invalid. Went to file preferences as directed.

In the file preferences, SU allowed correction of all but the template file location path:
Preferences
The button for editing the template file location path is greyed out and inoperable!

I’ve tried completely wiping out SketchUp from the machine and reloading fresh, only to have the same problem. Can anyone help?? Thanks!!

When you did this did you right click on the downloaded installer and choose Run as administrator? If not, close Sketchup, find the installer file you downloaded, right click on it, choose Run as administrator and then choose Repair when prompted.

The Templates folder location is not editable and likely permissions weren’t sufficient for it to be created or accessed.

Thanks for the tip. Unfortunately, repairing as administrator did not work. I also tried removing and reinstalling fresh as an administrator to no avail. Is there a registry entry that might have migrated over from the old machine when I copied files over??

The template location can be edited in this file:

%LocalAppData%\SketchUp\SketchUp 2020\SketchUp\PrivatePreferences.json

It’s in the file locations sections. Or, you could delete that file, when it gets regenerated it will have the right template location.

Make sure you have closed SketchUp before editing or deleting the file.

Thanks, Colin! Deleting the .json file, then starting SketchUp did the trick. You’re awesome!!