Intersect Faces question

I’ve 3D scanned part of an old house architectural detail and would like to be able to carve this detail on my CNC machine.
In the attached file is the scanned part, and then a profile which I would like to be the boundary where I can delete the excess rough edge of the scan. My challenge is that when I select the scanned part and the desired profile and try to use the “intersect faces with selection” option, my computer gets a never ending pinwheel. This happens even when I try to do this with a much smaller section of the scan.Any ideas or suggestions? If there is some other way to achieve this I’d be happy to know as well.

Scanned Detail.skp (3.9 MB)

Computer: Mac
SketchUp Pro Version 23.1.341
Processor: 4.2 GHz Quad-Core Intel Core i7
Graphics: Radeon Pro 580 8 GB
Memory: 16 GB 2400 MHz DDR4

Could you put this information on your profile please.

Are you still using MacOS Sierra?

Sorry…I’m not too frequent on this forum, so I guess I’m not dialed in as well as I should be here. In my settings, I do not see where I can add the technical information to my profile. Do you know how I can do this? I am currently running Ventura 13.6.4


So, about your issue, yeah, you’re trying to intersect A LOT of small faces, it takes time :slight_smile:
You might want to consider softening the whole terrain before intersection, makes it easier to grab the extra bit / see if the cut worked.

(also, you have of tiny holes, I guess it’s the result of the scan)

then enter the group, intersect with context, and wait. I’m at 5 min here, still rolling

Nah forget about intersection.
I tried, got a messy result.

But using the sandbox Drape tool worked better.
Capture d’écran 2024-02-23 à 16.29.10

First, I scaled you model up 1000times, to avoid the small faces effect.

then, from your cutting shape, I only kept the top. and moved it up a bit.

select the cutting shape, click on drape, then click on the scanned part.

here I painted it orange. you can also delete it if you want.
(I accidentally ungrouped the scanned part earlier, it has no incidence right now though)

same for the other sides, draw the cutting line, make it float above the face, drape it onto it, remove extra bits.

Scanned Detail.skp (4.1 MB)

and when you’re done, you can scale back down at a ratio of 0,001 to return to the original size.
(it’s a good idea when working with 3d scanned object to import them 1000times bigger, fewer holes. same for 3d printing)

Thank you!..this is a great tip and I see it works on my end.

I’m new to 3D scanning so in regards to importing scans 1000 times bigger, is there a way you can recommend that I might scale an stl. file 1000x before I import it into SketchUp?

uuuuh not sure, I think when you import you can do something… or in an external exporter ?

I haven’t opened a STL file in ages, can’t remember, but @DaveR models and prints small stuf (screws, tiny pieces), and @Cotty as well, they might have a bette imput on this part than I will.

all I know for sure is that when it comes to files with super tiny faces, if possible, it’s better to import / work with them at bigger scales (100, 1000x) because you’ll get rid of the “tiny” faces issue where they disappear. :slight_smile:

Ok gotcha - I can explore a bit more on that topic…but thanks for bringing it up as a general concept :slight_smile:

In the import dialog, there’s a button “options” where you can choose the units of the STL file. I always use meters and scale down later on if necessary.

1 Like

Hmm…interesting. Thanks, I will see if this has a positive effect on this issue.