Internal component lines

I’ve been using SketchUp for years with enjoyment and success, mastering the tools I have needed. I the current model, all of a sudden my components show internal lines and I nom longer have the ability to use the push/pull on some components. When I select a component and then double click on a face to enable the push/pull feature, it opens the component behind the component I want to work on. I am completely lost. Any ideas?

Thanks in advance.

Perhaps you could share the model so we can see what you are describing. If these are just softened edges on the faces you could try erasing them. If the geometry has become distorted erasing those edges could make faces disappear. Then some other fix is required.

I wonder if back-edges (K) or X-ray view mode has been enabled?

1 Like

Hi Dave R,
Ok, so this is weird. I decided that instead of sharing the whole file (a cabin renovation), I would copy and paste the components that I was having problems with - in this case some lower kitchen cabinets and countertops. When I copied and pasted them into a new file so they were isolated, the internal lines were not there and the push / pull feature worked as normal!!

Hmmmm… Weird indeed. It would still be helpful to see the model file where the problem exists.

It does look like an x-ray. How do I turn that off?

Do I upload it here, Dave R?

X-ray is a Face Style setting. You can change that in View>Face Styles or in the Styles panel. If it’s the Back Edges, tap K to make them go away.

Yes. Drag the .skp file into a reply. Or, if it’s too large to upload directly, upload it to Drop Box and share the link.

Dave R!!! Holy ■■■■!! I tapped K and they disappeared! I cannot thank you enough. I was totally lost and stalled in this design. Thank you so much!!

Xray = View > Face Style > Xray > toggle on / off [there’s also a Toolbar with button toggle…]
Back-edges set in Style
K = toggle on / off…
EDIT: late to the party by 1 min !

@TDahl gave the hint in his post.

1 Like

BTW the word that was blanked out in my thanks message was c r a p. What has this world come to when that is offensive but so much else is allowed??

1 Like

Thank you TDahl. I missed your reply!!

1 Like

Thank you to you as well, TIG!

This is my first time using a Forum for help and I am totally impressed with the speed and knowledge shared. Problem resolved. Thanks again, everyone!!


We’ve been sitting here waiting for you to ask your question. :stuck_out_tongue_winking_eye:

1 Like