Installer is damaged and can't be opened - Sketchup Pro 2020 and MacOS Catalina

I’ve seen the posts indicating that Sketchup Pro 2019 displayed a message about the application being “damaged and can’t be opened” when used with MacOS Catalina. The solution posted was to reinstall the software. However, what is the solution when the installer itself results in that same error?


My first shot would to try downloading a new copy of the installer. It may have been damaged during transit.

There is a pre-Catalina issue where a DMG file may claim to be damaged. The solution was to go into System Preferences, Security & Privacy/General, and change the options for where apps can be downloaded from. Previously you could set it to Anywhere, but now the best you have is App Store and identified developers. Try that, and then when trying to use the DMG look at the same area to see if you are being asked for more permissions.

Is there a reason you are trying 2019 and not 2020?

I apologize for the confusion. I’m installing 2020 as noted in the title. In the body, I was saying that I’ve read forum entries about similar issues with the application itself in version 2019. I’ve tried downloading multiple times. I’m getting a zip file containing the Mac installer and not a dmg file.

Which browser are you using for the download? Safari should download and unzip the file to give you a .app file, and it may do that better than Chrome. Though both should work ok.

If you can’t get it working I can give you a SketchUp 2020 folder to put into Applications.

I’ve tried both Safari and Chrome. And I also tried the “offline” version of the installer. The unzip does produce a “.app” file, but that file is the one that generates the error when I launch it.

Someone else is having a similar issue. Can you open Terminal, and paste in this line:

sudo ~/Downloads/Install\ SketchUp\ Pro\\ to\ Install\ SketchUp

You have to type your password after pressing Return. What errors, if any, show up?

No errors in Terminal, but the same popup occurred (file is damaged and a move-to-trash prompt).

I have a customer with the same issue. Have tried downloading the installer from two different sites. Same error…


User has downloaded Sketchup Pro 2019 and installed that without errors.

This message used to come up in older versions of Mac OS. The solution was to go into System Preferences, Security & Privacy, and change the options for where apps can be downloaded from.

Nope, that didn’t work, same problem

I will send you a message.

Problem solved, thanks Colin