Install of Applinax Site Viewer app is preventing SU2017 from booting up

viewer
applinax

#1

Hi all,

I’ve managed to get myself into a spot of bother… Any help would be greatly appreciated.

• I installed http://extensions.sketchup.com/en/content/timms-site-viewer to evaluate it. However, even since doing so my SU2017 no longer loads up successfully.
o The SU window opened, but then immediately froze and no error message was displaying. Uninstalling and reinstalling did not resolve the issue.
• I installed Site Viewer (SV) on SU2016 and SU2015, both of which started up fine.
• I have since uninstalled SV on both SU2015 and SU2016 in an attempt to get SU2017 to work, but with no joy. Uninstalled and reinstalled SU2017 a few times during this process.
• I did at least start to receive an error message, “Error loading file applanix_sitepbllisher/install.rb, could not find included rile ‘applanix_sitepublisher/install.rb’.”
• I have since removed all references to Applanix and TIMMs site viewer from SU2017 relevant sections of the registry, still to no avail. Uninstalled and reinstalled 2017 again.
• There are numerous help articles regarding “Error loading file …” but none seem to directly address this situation.
• I have emailed Applinax support with the above request for assistance and their response was to send me the installation instructions, which was far from helpful. I’ve written back to them and am awaiting their reply. Have also emailed SU support.
• I’m guessing there is a way to remove all references to the SV plug-in such that SU2017 doesn’t try and load it. But I’m not sure how to do this from outside of SU2017.

Please let me know what other (if any) information I can provide that might help you help me…

Thanks again,

James


#2

under Windows go to C:\Users\<username>\AppData\Roaming\SketchUp\SketchUp 201#\SketchUp\Plugins\ and remove the concerning Ruby scripts incl. subdirectory of the affected extension.

(macOS: Finder : Option Key : Go : Library : Application Support : SketchUp 201# : SketchUp : Plugins)


#3

You are missing a tilde ~ character and a forward slash before Library.

It should be:
~/Library/Application Support/SketchUp 201#/SketchUp/Plugins

Start in Finder with Go, Go to folder then enter ~/Library if it isn’t the default, and step your way down the hierarchy as above.


#4

no path required if selecting the option “Library” from the dropdown list shown.


#5

SU 8 and older versions used the "systemwide’ /Library/Application Support folder on Mac. Later versions use the User’s ~/Library/… folder.

Does using the Option key as you suggest get you to the User Library folder? I’m still relatively new to Mac after many many years using Windows.


#6

yep… or press “Shift+⌘+L”.

alternatively you can enter the follwing piece of Ruby code to the “Window > Ruby Console” window of SketchUp:

UI.openURL("file://#{Sketchup.find_support_file("Plugins")}")


#7

Thanks for clarification


#8

sketch3d_de & john_mcclenahan,

thank you both for your contributions, thanks to your help my SU2017 now successfully loads.
Sorry for not clarifying my OS in the OP. I’ll add that information to my profile now.

Many many thanks,

James


#9

This topic was automatically closed after 91 days. New replies are no longer allowed.