SU Pro 2021-0-391-128

Hi,
I have an issue installing and updateing SU. Everything works fine, but I’am a bit confused
Attached a screen and the logfile (zip).
Installing SU Pro 2021|690x369 InstallShield.zip (48.2 KB)

If you have SketchUp Pro, there is no real need for the Viewer (Unless you want to check how your model would appear)
It seems there is something stuck with the Viewer Installer , by the looks of its icon (Blue Arrow)
Are you trying to remove it?

In what order did you do the installs?

Here’s what I would do:

  • restart or better, reboot the computer, this will stop all ongoing processes.
  • Rightclick on the Viewer’s installer file and choose ‘Run as administrator’
    when prompted, choose desired action ('repair’for keeping the Viewer App, ‘remove’ for …)

If anything goes bad after this ( pop-up for missing .dll files or anything) Remove the Visual libraries that came with the installation (both 2015-2019 versions)

After removing, do a restart.
Then repair the Installation of SketchUp Pro by rightclicking on that installer file and choose ‘Run as administrator’
That should reinstall the right Visual library needed for SketchUp again.

Mike, I’m not installing the viewer.

I started SU to work with and instead a message poped up for installing an update. Then the installation stopped with the message not to find the file in that path. I did not find it too. It seems to be installed. Maybe in a wrong path. I have no idea. The installation log does not look good. The installation bar turned red from green.
I don’t know how to install the missing file or where to remove .dll files.
The same issue appeard by updating from SU2020 to SU2021.

Mike mentioned the viewer because in the screenshot you showed you had installed SketchUp Viewer, and you also had it highlighted.

I wonder if you had previously installed language packs, and if something was going wrong there. Try this version of the installer, it has all the language packs included, and doesn’t have to get them from an online file. See if this one does better:

1 Like

Oh, sorry, I marked the wrong file.

I download the offline version and tried a lot. On my new laptop an error is shown allways.
Then I tried on my old laptop and everything was fine. So I have to fight with my new laptop, grrr.

Thanks for your help.