Help to install...missing dll...?


#1

Hello hello…!
I am not able to install Sketchup 17…there is a dll missing: api-ms-win-runtime-[1-1-0.dll.
The sketchup thumbsup is not satisfied…Has anyone any help with this…?
Greetings for now…Jakob Hovman.


#2

Right-click the installer, and choose “Run as administrator”.
(Application installers need to be run with administrative priviliges.)


#3

Hello Dan…Thank You for replying…!

I read this on the Pro question…
and tried it…(I am administrator though)…and it did not Work differently:
"Thumbsup.dll failed to register HRESULT -2147024770 Contact your support personel"
Original message: “api-ms-win-runtime-[1-1-0.dll is missing on this pc”

Do you have any idea what can be wrong and/or done…?

Again thank You for a quick reply…! Jakob.


#4

I suggest you update your windows installation. Once I did this my SU2017 installation was a lot more stable.


#5

Hello Julian…Thank You for replying…I will do that.


#6

Same problem here, I have been unable to install “SketchUp Make” today, and I have tried several times, and always the same message:
“Thumbsup.dll failed to register HRESULT -2147024770 Contact your support personel”

I use windows 7 64 bit.


#7

Did you right click on the installer and choose “Run as administrator”?


#8

Yes, twice.I’ll try again.

P.S. Impossible, even I tried disabling the antivirus


#9

Hello Ton…I googled the dll and found a few videos on you tube about it…

The dll is part of Visual C + +

“Visual C++ Redistributable for Visual Studio 2015”

link to Msn: https://www.microsoft.com/en-ph/download/details.aspx?id=48145

They want us to remove it… restart… and install it again.

Link to tube: https://www.youtube.com/watch?v=JsVhxhPg22A

Try it…I tried it, but my lap top is not connecting with win update…
Good luck…Jakob.


#10

Thank you very much JakobHovman :wink:, really is very good to know that, I’ll try.

In any case I have installed SketchUp Make 2016, and seems it works fine.

Thanks, again.:smiley:

ton.


#11

Hello Ton… Good to hear from You…good solution you made for now…!
I use Sketchup Make 2015,

I would like to try this S17 version though…
It gets high praise on YouTube.

Early Winter greetings from Denmark…Jakob.


#12

Review 2017 not launching, especially #3, installing Visual C++ runtime library and .NET framework separately from Windows update. The SU installer usually can install these things if missing on your system, but sometimes it doesn’t happen.


#13

Hello Cata…Thank You for replying…You are right…I deleted and
installed Visual C++ and NETAgain. S17 finally got installed, only to tell
me, my graphic Card needed an updated driver…!
All I wanted was to try the new S17 and make 3D sketches . Back to S15…!


#14

Things have changed with SU17, hardware acceleration is now required. That means your graphics driver needs to supply OpenGL 3.0 functionality. It’s not time to throw in the towel regarding your graphics card until you’ve exhausted hunting for the latest driver maxing out the OpenGL capacity of your card. The graphic card info in your profile is a bit limited to assess it right off. Try your computer manufacturer and then card manufacturer for latest updates - don’t rely on what Windows Updates indicates is available.


#15

Hello Cata…Thank You for replying…a true entrepeneur you are…!

You are right…I will not throw any towel anywhere…
just taking a short break from machine and software chrunchng.

Yes… NeXT step is to get OpenGL 3.0 into play.
Thank You for the encouragement…
S17 sounds very promising for us users.

Early Winter greetings from Denmark…
and Again thank You for your reply…
Jakob.