Inspector windows don't show up on multiple displays

inspector
dialogs

#1

When opening SketchUp using multiple displays, the windows (layers, styles, scenes, etc) consistently don’t show up. For some reason I cannot get them to display no matter what I do. This has happened in multiple versions of SketchUp and was just an annoyance, but has become a hindrance. .


#2

This can be an issue if you change monitor layout, disconnect often or your system want to move monitors randomly.
The main fix is to go to Window/Preferences/Workspace and hit the Reset Workspace button.
If you are unable to get to the Preferences window as it appears to open off screen, Go Window/Preferences then alt and space together, then hit m, then any arrow key and finally move the mouse around until the preferences window shows up, and hit the reset workspace button.
To avoid this if you are using a laptop and docking to multiple screens, make sure you set the graphic options back to just the laptop before you disconnect.


#3

Thanks! I would think this is something that could be fixed by just making the menus default to the same display as the main program, but it is an issue that has come up version after version consistently. And because of the nature of my job, I do take my laptop from dock to non-dock scenarios quite often and this is a hindrance.
In any event, thank you for your assistance, this is a tremendous help.


#4

Unfortunately I don’t think it is caused by sketchup, I believe it is a windows issue, I may be wrong. But I first became aware of the issue using Corel Draw and multi screens. I’ve also seen it with other programs. But knowing the alt space move to get windows back has saved me many times.


#5

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.