Insert model not updated version #layout

update
model-reference

#1

Hi had a spot of trouble figuring out what my issue was - I couldn’t figure out why it was happening:

When I inserted a model view into Layout, from an ‘active’ sketchup model (in Sketchup itself) that was just saved…
Then when I go to inserting the same file, only just previously saved in Sketchup, it doesn’t load in the current version, but an older version.

Is this right? Can you emulate it? I am guessing it’s happening to me because I have previously uploaded a version of the model in previous sessions and the Layout file uses the old reference. Surely inserting a file should upload the current file, not an older one that no longer exists?

Thanks in advance


#2

Are you inserting the same SketchUp file more than once into the same LayOut file?


#3

Hi Dave, how are you.

Well I did need to (two sections of the schematic which don’t fit to scale on the page ‘as one whole image’), but that’s not where the issue has arisen. I should say it did resolve when I used ‘update model reference’, but what I am really asking is why did it not load in the up-to-date Sketchup file, rater than loading in a previous, older version of the file… which has been overwritten…


#4

Hi Ian,

I’m doing well, thank you. And other than your little carborundum here, I hope you are well.

Not clear exactly on your workflow here. Did you use File>Insert for the second viewport or did you simply copy the first one. The latter is really the way you should make additional viewports once the first one is into LO.

In any case, until you do the ‘Update model reference’ changes you’ve made to the original SketchUp file won’t show in LO. Remember that the LO file is a package that contains a copy of the SketchUp file along with the other entities such as images, imported text, and so on. The viewports in LO are getting their scene info from that copy of the LO file, not your original file that you’ve been working on.

When you make edits to the original SketchUp file, you are creating a different file than the one contained in the LO file package. In order to get the viewports to show the changes in the original SketchUp file, you have to make LO replace the original copy of the SKP file it holds with your edited one. That’s what happens when you choose Update model reference.

This has some cool benefits. First, your document won’t change until you’re ready for it to do so. Second, it means that you could replace the original SKP file with an entirely different one. There are a couple of caveats to that but it can be done.

Now, if you would like the viewports to update automatically when you edit and save the file, that’s also possible. Instead of opening the original SKP file directly in SketchUp, right click on a viewport and choose Open with SketchUp. Make your edits and save. When you return to LO, the viewports will be updated with the changes assuming you have rendering set to Auto. What you are doing here, though, is opening the copy of the SKP file that resides in the LO file package. (In SU, hit File>Save as… and check out the file name and save location.)

Does that help at all?


#5

The perfect answer, cheers!

Yes I did make a copy for the second viewport.

It’s the latter part of your post which is the most useful to me, explaining how Layout keeps the Sketchup file separate, unless I open the file and edit it from Layout. That is a nice touch and gets round the confusion which could occur when using cross referenced file etc I’m guessing.

Thanks again


#6

I’m glad that helped.

I would probably reword that to somethng like, “unless I open the Sketchup file from LayOut.” No confusion with the idea of double clicking on the viewport to modify camera position. Some users think that’s editing the SKP file which it isn’t. That just creates a disconnect which usually causes problems later.

Yes. I think so.

Normally when you open an existing file in LayOut, it goes out to find the original SKP file to see if it is different from the one in the package. If it is, you get a message to that effect and you can let LO update it’s reference file to match. If you don’t want LayOut to look at the original SketchUp file anymore, you can unlink the reference which results in it using only the embedded version.

When you send me a LayOut file to look at, you don’t need to send the SKP file because you’re sending it inside the LO package. Of course you also realize, you’re sending away your SKP file if you send off the LO file. You’re handing over the basket with the eggs in it.

When I open your LO file, though, it will show the reference as missing since my computer can’t access the file on your computer but I still have the file that the viewports are generated from.

This same sort of thing happens with imported images, RTF, and XLSX files, too.


#7

done :wink:


#8

Thanks guys.
I have been going back and forth between Sketchup and Layout as many as 15 times in an editing session and wondered if there was a way to eliminate the need to repeatedly… select LO’s Document Setup, select References, select the model filename, select update, and finally select close.

I’ll be right clicking viewports to edit my Sketchup models from now on.

Thanks again!


#9

Bob, there’s another option, too. Close the SketchUp file if it’s open. Right click on a viewport and choose Open with SketchUp. If you need to edit the model. Save the changes and return to LO. The updates will get done without you even having to right click to select Update Reference.


#10

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.