Incomplete elements import from AutoCAD

Why is it that there are only few elements, as in literally few, that were imported to my SketchUp from AutoCAD? In my case, I was assigned by my professor to do a 3D model of a restaurant interior then surprisingly, I only see a vertical line in my SketchUp? Can someone please help me? :frowning:

Did the person who created the file draw correctly in Autocad?
Are all the elements (vertices, lines, etc) at the same elevation? Or a line that was supposed to be 2D was drawn in 3D, with the end points at a great distance ??

https://help.sketchup.com/en/sketchup/importing-and-exporting-cad-files

Hey! Thank you so much for the reply.

Well I suppose, considering it was from a professor from an institution. I’ve tried zooming out from the model, or even clicking the zoom extents, but I still can’t find it. Now, I’m studying about the image you sent me about the unsupported files, especially the XRef and the ADT/ARX objects. I’m quite unfamiliar with these things.

If you have Xrefs in Autocad, use the Bind command (Bind converts the objects in the xref into a block reference).

Learn about importing dwg/dxf

My blockmate sent a file already. So I won’t problem it anymore. But according to him, the problem was with the scaling of the AutoCAD file. I haven’t noticed that it was still in millimeters, though it was kind of in meters (but annotations were in millimeters). I think I messed up what I said. I don’t know if you can imagine what I’m saying. But all the more, thank you so much for the effort! Problem solved.

1 Like