In Mac OSX Yosemite, the texture edit menu will not appear

texture
mac
curves

#1

Okay, I have now spent about 30 hours trying to target the problem, but I am utterly exhausted by my failure. In short, I had a baseball cap, imported from the 3D warehouse, to which I have made a whole bunch of modifications. In addition to these modifications, I also wished to overlay a photo of the inside of a baseball cap onto the inside of the Sketchup, 3D Warehouse, baseball cap.

I understand that this requires texture and paintbox skill. I also understand that groups and components (which the 3D warehouse cap possessed in spades) must be disabled before messing around with textures… Finally, I understand that the cap’s curved surfaces present a problem.

Long story only slightly longer, I was and am able to overlay, on the inside of the cap - with help from paintbox - my imported photo. So now I am sooooo close to getting where and what I want.

Unfortunatley, the last step, editing the texture so that it alligns with the object in which it was placed, is impossible, because when I right click on the new texture surface, the texture edit menu will not appear. Nothing. Nada.

So now I can not properly position my image to the inside of the cap it has been imported into.

I have tried the following:

  1. Searched like heck all over that 3d model cap and can not find any groups or components that I have not exploded already.

  2. right clicked til I’m blue in the face all over that cap.

  3. It should be noted that I imported another cap and had the same problem. However, I “right clicked” on a different item I’d not imported, which I’d just created in sketchpro, and there - wahlah! - was the texture edit menu. In other words, the menu only fails to appear where I need it … with this cap.

Help please!

Thanks!!!

Erik


#2

The standard texture tool will only be available when you select a single flat face.
Turn on hidden geometry and right click on one facet and position the texture. Then resample that facet and pain the others.
You may find it won’t work all round the inside of the hat.
You may want to look at a plugin such as Fredo’s ThruPaint to work with curved textures.


#3

Thanks. I’ll check out Fredo’s. I’ve tried the hidden geometry/flat face thing with little success thus far. That said, if you’re still around, I found another problem.

Assuming my issue was just as you’d suggested, I kept downloading caps until I found one that worked every time (my texture … edit menu showed up.

So I painted the inside of the cap, activated the position tool, and then … nothing.

Any idea, of how I’m supposed to end that positioning process? You finish and there are basically two options I can see, either click outside of the cap or go through the texture right click menu and click “done.”

Neither one led to my seeing a change in the pasted picture.

Most importantly, though. I wanted to say thank you very much for taking the time to write back about my problem. I’m going to go check out Fredo’s!