Problem with Texture Position Tool


#1

I have Sketchup Make 2015, and the Free Version of Sketchup 8 running in separate directories, when I import texture, I cannot get “Position” tool when right clicking on selected polygon, (its not in the list of tools) its as if the Position tool has been de-activated… what’s wrong???


#2

how are you importing it?
what are your 2d Import settings?
what system?


#3

When you Import an image file there are several options on how you might use it into your Model…

If you Import an image file as an Image it is not editable with the Texture tool.

If you have used the image file as a Texture in a Material, then the Texture > Position tool will appear in the context-menu if you have applied that Material onto a Face and you now have that only Face Selected [i.e. the one Face and no other Geometry like its Edges, or other Faces in the Selection].

If you have applied that Material onto a ‘Surface’ the Texture tool will not appear - a Surface has multiple Faces: is you switch ON View > Hidden Geometry you will see the smoothed edges as dotted lines, Select one Face a adjust the Texture of that… you can then use the ‘eye-dropper’ to sample that Material, getting its UV-mapping, and then apply that onto the other Faces in the Surface [Hidden Geometry back OFF…].

If you have applied that Material onto a Group or Component Instance, then the Texture tool does not appear.

If during an Edit you have applied that Material onto a Face which is inside a Group or Component context, then if you have exited that Edit you cannot access the Texture tool from outside the context - you must re-Edit and Select the Face inside its context - then the Texture tool will become available…

If the Material of a Selected Face has no associated Texture, then you will not get the Texture tool - because there is nothing to be processed.


#4

Make sure that you are actually selecting the face only; no lines, edges or groups in your selection.

If you Double click on the surface, it should select the surface and all connected edges - if it does this, then just click once on the surface again. (You may find that it’s part of a group and if so, will go into the group when you double click.)


#5

Awsome, TIG, you have just solved ALL my problems, Im back in business… thank you SO much!! (It was the “use as texture” option I needed to click on) Now to be greedy, I have another question, IS there a plugin that allows textures to be WRAPPED around circular shapes rather than resorting to the “Project texture” tool… that I can download somewhere?

thanks again


#6

Look at Fredo’s ThruPaint in this toolset
http://sketchucation.com/pluginstore?pln=FredoTools
You’ll also need his Lib
http://sketchucation.com/pluginstore?pln=LibFredo6

Or Whaat’s tools like
http://sketchucation.com/pluginstore?pln=DM_SketchUV
http://sketchucation.com/pluginstore?pln=UVtools
http://sketchucation.com/pluginstore?pln=UVtools_pro

There’s also thomthom’s
http://sketchucation.com/pluginstore?pln=tt_uv_toolkit


#7

Ok I will, I already have Fredo 6’s library and toolset for curviloft, mirror, etc, but not his Thrupaint one. Just quickly, what is your recommendation out of the 3 toolsets you listed? I want to be able to wrap textures around cylindrical objects without distortion you get when using the “project” texture tool.

thanks :slight_smile:


#8

Try Whaat’s tools,


#9

Ok, thanks for all your help… much appreciated


#10

Hi!
I have downloaded SketchUp Make 2017 and find that I can’t access texture position tool.
I select the surface only (without edges, etc) and right click…but the option to modify texture is on available. Please see attached screenshot. Do you know what am I doing wrong? Thank you!


#11

Is it possible the surface is more than one face? Turn on hidden geometry? Is the surface divided into more than one face? If that is the case, Texture won’t show in the Context menu. Or, if the texture isn’t applied to the face you have selected but is instead applied to the container, you’d see the same thing.


#12

Thanks DaveR! You are spot on! I had the texture applied to the whole box, not to the face…
After I applied it to the face the context menu for texture showed up. Thanks a lot!