Texture options/tools missing from context menu for some reason

export

#1

v.2018

This is embarrassing… I’ve been using sketchup for more than 10 years, and I can’t find the texture positioning tools/commands. It’s missing from the context menu for some reason.

Tried digging through F1, forums, etc…

Just tried a couple of things… found that I can re-position the texture when it is not in a group, but I can’t do it when it is in a group. In v2017, this is not the case…

Forum interface is tricky for arranging images… Versions (2017 vs 2018) can be visible in teeny tiny text in the upper left corner of each image…

Maybe there is something in the file settings for this? I’ll do a little more digging, but I need to get back to work here…


#2

The only time the context menu Texture tools are available is when the texture is applied to a face, not a group or component, AND you are right clicking on a single face. If it’s multiple faces with softened edges between, the tools won’t be abvailable.

First screen shot shows the texture is applied to the face. Back face in that example.
Second screen shot shows the group is open for editing and the texture is applied to the back face.
Third screen shot shows shows the same as the first.
Fourth screen shot shows the same as the first. Maybe you uploaded the same image twice.
Fifth screen shot shows that the selected face has the default colors applied to it, not the texture so the texture tools wouldn’t show. The texture is applied to the group/component container, instead. This is expected behavior and has always worked this way.

Generally it’s not a good idea to apply textures to group/component containers.


#3

Thanks for the quick reply, Dave!

The issue was tricky to re-create, but I found it. It seems like a tricky process… quirk?

  • When I draw a rectangle, extrude it, make all six rectangles a solid group, then deselect, grab the paint bucket and apply it to the group, then activate the group, select a face/right click on a face, context menu does not have texture options.

  • When I draw a rectangle, extrude it, make all six rectangles a solid group, then activate the group, grab the paint bucket, triple-click to select all of the faces, use the paint bucket to apply all textures to the group at once, the context menu does have the texture options…

I’ll do a little more searching, but if anyone can chime in with a quick fix to this…?

Thanks!


#4

I don’t see that there’s anything tricky about this. If the texture is applied to a group or component container, you can’t edit the position or orientation with Texture>Position. The texture must be applied to the face and if the face is inside a component or group container, that component or group must be opened for editing so you can access the face inside.

The quick fix is simple. Don’t apply textures to components or groups. Only apply them to faces. And, if you want to edit the texture position or orientation, open the group or component for editing and right click on the face.

There’s nothing more you need to search for on this. That’s the way the tool has always worked.


#5

The issue is that I AM working with the group active (opened for editing) when I select the texture and right-click on the face.


#6

The evidence in your screen shot of the service counter indicates the texture is not applied to the face. It is applied to the group or component. Entity Info shows the material/color applied to the selected face.


#7

it really doesn’t even make sense to re-position the texture on all faces of a group or component…unless of course it only has one. I usually open to edit select the face apply the texture then re-position from the context menu. If the texture position isn’t critical I will apply it to the group. Does that, or can that, have undesirable effects? (given all faces are oriented properly) I have always assumed it was ok given that it’s rather default.


#8

It’s not really a problem if you have no need to control the position of the texture. My preference is to leave myself the option and apply the material to the faces. It’s another one of those consistent workflow things.


#9

If the texture has been applied to the group, when you want to edit the texture of a face, you would need to context click and “make unique texture” then you can use the “texture” re-position as normal. Unfortunately textures don’t map to a group very well (if at all) unless its a fairly homogeneous texture.
So it would always be better to apply textures to discreet faces in the first place as you will have to do the additional work later to line everything up anyway.


#10

Okay, I figured out a quick fix/work flow for this.


So, I discovered this issue after making lots and lots of them. (it’s a group and not a component) (also, be patient, this is detail development, and I do know that I could make a good texture without modeling every board for this assembly. Please, be patient).

What I have is a place where it would be nice to have things re-positioned just a little bit because of how repetitive the texture is.

…and the texture options are missing from the context menu… as discussed earlier.

So, a really quick fix I’ve found:

  1. Select single face,
  2. [B]ucket tool,
  3. [alt]+Click in face (for eye dropper/sample),
  4. Click,
  5. right-click. And now I have the Texture options in the context menu.

Yay! I’ve solved a problem that I wouldn’t have if I didn’t do it wrong to begin with! Huzzah!

Happy Friday, drinks on me.


#11

Selecting the single face with the material applied to it is critical for being able to access the texture positioning controls.

I don’t like the repetition that is common with wood grain textures either. The long board textures I make help get around that problem. This one isn’t quite the same but I have several 4’x8’ “sheets” of plywood so I can pick and choose the part of it I want to use. In this case the textures are hand drawn to give the impression of the plywood but I also have photographic textures of entire boards for solid wood.

Have a good weekend. Since you’re buying, I’ll have whatever you’re having.