Need help - I am really confused as a beginner! EDIT: NEARLY SOLVED!

I am following a tutorial on how to add texture to an object. I have not followed the entire video as I already have an object to which I want to add the texture. But somehow my menu differs from the menu used in the video. I have made screenshots of my 2016 Sketchup interface and also from the video. The part where I have to “right-click”, then go to “texture” and choose “projected” is not appearing on my menu! My menu show ‘add photo texture’ but it do not bring up projected as per the video. What should I do to get the image onto the bag?

As a beginner I get very confused when things differ like this. I am starting learning at age over 60 and can’t think straight here. :roll_eyes:

Any help is much appreciated!

Thank you,

Laura

Video is this one I am following:

You are not getting the “Texture” option in the contextual menu. this may be because you have selected something along with the surface prior to right click. You can only have that one surface selected (or nothing) when you make the right click (no edges etc.)-- to get the contextual menu to display the “Texture” option. It looks like you have it right, so otherwise I cannot tell.

Another thought-- I see a blue area selected toward the top, but I don’t see the “dots” indicating selection at the lower portion where the image is. Could it be you have a couple surfaces there and not one, or you imported the image file as an “image” and not a texture? Make sure your surface below the bag is facing upward (white). Make sure the texture is applied over that whole surface (as “texture”) when you import it. See the options at the bottom of the import window.

The contextual menu choices change with the object selected.

The Texture menu item only appears in the Context menu if you have a texture applied to a face and you are selecting a single face. In your screen shot I see no texture and you have multiple faces. Apply a texture and turn on Hidden Geometry so you can right click on a single face.

1 Like

Thank you for your time to reply. I guess I must just play more with this. I saw that the image I want to add to the bag is not filling up the whole block anyway. Well, just have to redo the steps as per the video and see what will happen. The way the person talks in the video is actually quite good for me as an old age beginner, lol.

DaveR, thank you for your input as well.

This is what I think I could be seeing.

Thank you. This makes sense to me now. Exactly what has happened. My texture was not fully added to block.

Still not working. I have redone the texture part and now only texture itself showing, no extra layers. If I move the ‘orbit’ tool I can even see the texture underneath!

Menu still not show ‘texture’ option to choose “projected”. I have moved the texture even closer to the object as shown in image. I have even moved the texture to middle of object to see if that will perhaps change but no!

I am a newbie thus not know what to do. How else can I get the image onto the pack? :thinking:

First… choose “Explode”, and then select again and you’ll see “Texture > Projected”
te-03

Thank you, I got that now. But now struggling with the next step to get texture going onto pack. I have looked at video, use the paint tool but texture still lying underneath. :thinking:

I have noticed texture bit wider than pack, could that be issue? As mentioned texture, projected worked.

te-05

“underneath” where?

Thank you for the tutorial. :smile: I will try that.

You must “Reverse Faces” for that blue surface.
blue1

Underneath the object (pack) as seen in my first images on this thread. I have strictly followed the video tutorial (link above) where the chips texture was also underneath.

I have noticed you used a texture from sketchup’s textures. I have made my own image in Photoshop. Should I load that then 1st to Sketchup textures? Sorry for all these questions but I have not a clue what I am doing as beginner.

Oops, only saw the new post by you now to reverse faces.

It does not really matter what texture you use, once you have logically learned how the software works.
Keep in mind to keep “white face” to see, not the “blue face”.

Thank you again! Reversed faces brought back an older texture. I have used a model from the Warehouse and want to add my own instead. This mean the older texture was still there yet not showing I assume. I thought it was removed when saving as blank.

You’re welcome!

You can easily see what materials you have in the drawing in “Materials Panel > In Model”. To delete unwanted ones, use the “Purge” command from “Window > Model Info”, and then, if there are still materials you want to get rid of, remove them from “Window > Materials > In Model

Thanks for all the info which is appreciated. I then have 1st to follow the removing unwanted textures before using the model.

At last something is happening but just have to work on my original image size and also resizing in Sketchup to fit the envelope fully. Currently image causing repeats on top and on bottom of envelope as seen in image attached. But now I get the idea! Sigh :sweat_smile:

TEXTURE%20ADDED%20TO%20ENVELOPE1