Impossible to reset my Trimble password

Hi there,
I tried to reset my Trimble password in order to access 3D warehouse. It’s been impossible since yesterday and I wonder why. (I did it in the past with success)
I also tried to create a new account with another e-mail address, and it didn’t work either.
In both cases I just had the same page remaining, as if I hadn’t press the RESET button…
I never received any mail to reset my password nor to create an account.
Can somebody help me to solve this please ?
Thanks, have a good day :wink:

Try this:
Open a private tab or incognito tab in your browser.
Go to the 3D warehouse. (
sign in there (either reset password or create new)
You should receive an activation mail or reset mail, now.

Then, close SketchUp, in Finder go to this location:

~/Library/Application Support/SketchUp 2020

and delete the Webcache folder. Then start SketchUp and sign in.

(If you select the pathname and righ tclick on it, you can choose to navigate to that folder:
Services->Show in Finder)

Thanks Mike !
Actually my password worked in a private tab, no need to change it :slight_smile:
Hope the second step is not important, because I don’t find any Webcache folder in my Finder (and your tip with the right click just got me in my Recent files, but not a specific Folder).
Thanks anyway for your quick answer !

I have seen what you first talked about, but I can’t remember at the moment what causes that issue. If you have developer tools going in Safari, you could type command-option-c at the time the Reset button didn’t work, and see if Console is reporting any errors.