Impossible to download model from 3D Warehouse

Hello!
I’m having troubles with 3D Warehouse using Sketchup Pro 2020. When I search for a model and press download nothing happens (download doesn’t starts).
I have the same problem if I use the online version of 3D Warehouse.
I tried also to change browser but I haven’t solved the problem.
What can I do now?

Clicking Download does not cause a download in the online version. It should show you a list of formats to choose from. Do you see that list?

To keep you going in the meantime, if you search for somethings from inside the Components tray you can find the one you like, and click on its thumbnail. That should download the model immediately, and you click somewhere in your scene to place it there.

Yes I see that list in the online version but when I click for example on “SketchUp 2020 model” nothing happen.

I’ve problem also with Components tray because if I search something on the searching bar it open directly the 3D warehouse and I don’t see the thumbnail below the searching bar

What browser are you using? I just hunted up that forklift in Chrome, clicked Download and then chose the 2020 version and I had the file nearly immediately. Note the lower left corner of the screen shot.

I use Google Chrome too but download doesn’t starts. I tried to check also in the download folder but i don’t have it.
I tried also Microsoft Edge but same problem.
No idea what to do now :frowning_face:

@colin will surely get you sorted out.

Clearly it is possible to download from the 3D Warehouse so where exactly your problem is, it’s hard to say.

On the components tray part of the problem, clicking on any text will open the 3D Warehouse window, clicking the thumbnail will download the model. Change the components tray setting to Details instead of List.

Before selecting SketchUp 2020, chose More Tools, Developer Tools, from the three dots menu. In the developer tools part of the window choose Console. Now select the SketchUp 2020 option and see if any errors appear.

It works in this way! :slightly_smiling_face:
But still don’t know why I can’t download model directly from 3D warehouse

Hello,
sorry could you send me a screenshot where is this section?
I haven’t found it and I still having problem with 3d warehouse

sorry i’ve found it now.
yes i’ve some errors when i try to download a model (see screenshot below).
What could it be the problem?
Cattura

Strange that I didn’t get an alert from your earlier reply. Can you twirl down the right facing black triangles, and do another screenshot?

@TheGuz can you get a developer to look at this?

We are looking at this now and will reply with an update.
Guz