Importing IFC in SU2023

That is strange and I have not experienced/seen it before…

Do you also experience this problem if you export the IFC model as a TrimBIM file from Trimble Connect Desktop and then open it in SketchUp Pro 2023?

Yes, same problem when importing as a TrimBIM

Can you share the ifc?

Try this link. I have uploaded it on

Nedladdning av A40-V100 (balkonger).ifc

It’s wrong for me as an IFC in SketchUp.

Correct in Trimble Connect.

Export as TrimBim and import into SketchUp

It’s correct.


I love the phrase/filetype TrimBim . Happy holidays folks

I have a problem similar to this and have no idea how to fix it. Off course i can try stuff like using other apps to recreate the file, but that doesnt seem like an option for an extension that uses ifc file. Cant ask my clients to use other apps to correct files that used to work in previous version.
Any ideas on why components are imported on different locations that where they should be?
Only thing i see is that all those wrongly positioned items contain an ifcSlab.

Importing this same file (made in su2021) into trimble connect or 2021 will give this result :slightly_smiling_face:

Are you using IFC importer plugin?

I used both native import and import plugin

What plugin?

It doesnt matter much which plugin i use, the native import gives the same result, but its bt_ifcmanager.

Also…importing the same file into SU 2021 gives the correct result. Only SU 2023 goes wrong.
And if i import the file from j.larsson i get his problem too. Must be a change in the ifc import in SU…

@tt_su Any ideas on this one?

Can you share the file to test on SketchUp for Mac? What SketchUp version are you opening it with? your profile says you are on SketchUp Pro 2018.

I get the same problem with the file @j.larsson shared :

Does that help?

Otherwise, here is mine (rename from .txt to .ifc)
demo_ifc.txt (9.8 MB)

I can’t download the file, t says:

File to download
Max number of downloads for file reached. Please contact the sender if you need to download the file. Sender: Anonymous user (not logged in)

I uploaded my file as well

I think it’s a windows version problem. I Think it’s ok.
Have you tried to disable certain plugins if it could be the reason? Long time ago I had one that modified something and I wasn’t able to import IFC files.


here is the file
foro file.skp (5.3 MB)

Sorry, i uploaded the wrong 1. This is the correct file :slight_smile:

test.ifc_zipped.txt (6.4 MB)

(its a zipfile containing 1 ifc file)

I have disabled all the plugins i run, same issue