Import Fail - IFC File


I’ve been sent a folder full of DWG files and an IFC file from an Architect for me to use as a base to work up the interiors for a client. I’ve imported and worked with DWG files plenty, but never IFC.

When I try and import the IFC file in a new blank document I get the error message “Import Failed”.

Any idea what the problem is and what the work round would be? Would be a lot easier to start with a 3d file as this house is massive.

Unfortunately I can’t help, because I’m suffering the same problem. Anyone got a solution?

A common cause is that the IFC version of the IFC model to be imported is not supported by SketchUp.
SketchUp supports at the moment only the version IFC2x3.

Nowadays I regularly see that IFC models are exported as IFC4.
In that case you will have to ask for a new IFC model that has been exported as IFC2x3.

Thanks nnijmeijer, I will try that.
Failing SketchUp supporting IFC4, a little more info from SketchUp in the error message would be useful in finding the workaround. eg “Import Failed - File type IFC4 not supported. Use file type IFC2x3.”


I would like to queue up here because I cannot import any IFCZIP files either - SU crashes completely without a message when importing.

I loaded Solibri app (Mac) and looked at the model – it seems ok and there in the info IFC File Schema it says Value: IFC2x3.
It also says that the IFC file was generated by ARCHICAD-64 21.0.0 Windows version (IFC add-on version: 5021 GER Full).

What else could I do? I have imported DWG quite often, but never IFC files. I tested SUPro 2020 and 2021 …

I haven’t generated any of those, but I understand that it is just an ordinary IFC file with ZIP compression so you could try renaming it with a ZIP extension and then uncompressing it with either Windows explorer or any ZIP processing application.
Another strategy would be to download and install the IFC Optimizer application from Solibri, open the file with it and save an optimized copy in a regular IFC format without compression.

that is actually a good idea – I tried that, but unfortunately the same happened: SU crashed when trying to import it

that is a good idea as well, thank you. I just did that, I registered again and loaded the IFC Optimizer and run it. It saved about 25% of the original file and I saved it as ICF (not IFCZIP).
– but again SU just crashed when trying to import the file.

I then found the IFC Importer extension from SimLab to import IFC Files to SketchUp, it is a 30 day trial version and installed it – it ran and a wheel rotated for about 3 or 4 min, but then just quit with nothing imported.

Could the file size be too big to import it to SU? The IFCZIP is 15 mb and the unzipped file is 7o mb, the optimized is 50 mb.

Size might of course be an issue. Another thing comes to my mind: is the IFC geolocated? Is it placed to real-world coordinates that might put the model thousands of kilometers from the model origin point? This might also cause problems, as the importer converts every object in the IFC file into an unique component that has its origin at the global model origin. IFC, it seems, doesn’t support instancing.

The Archicad version used, BTW, might still have a bug in its IFC exporter that, if the model contains a “survey point” object, uses its coordinate transformation in the export even if you have told it not to do that but use the local model coordinates instead.

aha, how could I find that out? And could that also be a cause of the abrupt crashes?
Simlab Importer did not crash, but there was no import - of course I checked that (edit - undo did not show any import).

So then I should ask for a new file, without geo location and coordinates and make sure it is IFC version 2x3? Would you suggest that?

Thank you very much!

Did you try zooming to extents after the import had “finished”? That might also show “nothing” if the extents are “astronomical”. If the import has worked you should also see a lot of stuff in the Components tray, In Model section.

thanks, yes i did check that as well as show all …
Maybe there is an IFC Importer for Blender?

yes, there is: BlenderBIM Add-on
but importing the file into blender ends with an error as well :frowning:

just for information: I don’t have a solution, but I received the file as a DWG, which now works wonderfully for me. However, I can see that the model is extremely complex – the import as IFC may therefore not have worked.