Importing DWG or DXF to SKP - Teigha error 313

dwg
error
dxf
import

#1

I had no issue importing files up until this morning. I get this pop up now. I have tried downsaving the CAD files and also downsaving the sketchup file before importing. This issue happens to all CAD files I try to import now.

I checked the file propoerties and it is not read-only. I also tried copying the CAD file to my desktop as well as copying the drawing into a new CAD file and neither methods solved the issue.

Would appreciate any help. Thank you!

UPDATE : I restarted my computer and now it works again. Still do not know the solution for it though.


#2

you can always use the free ‘Teigha Viewer’ for evaluating the readability and content of a DWG/DXF as well as down-saving to an older version (e.g. r2000 compatbile w/ allmost everything).


#3

Possibly a memory leak from some application corrupted that part of memory where the CAD import library was loaded. When weird things happen, a reboot is a good idea (and so is saving your work often.)


#4

Thank you for your help!


#5

Thank you for your help. It happened again and so far a reboot is the only solution. Thanks again!


#6

Custom ARX objects, which typically do have more specialized capabilities than standard objects, are created and interpreted by Adesk products only and can lead a DWG/DXF import in other applications, because of the extended entity data, to fail (buffer overflow etc.).


#7

If possible, upload a small DWG file that causes you trouble - it is easier to help if one can have a look at the data.


#8

This topic was automatically closed after 91 days. New replies are no longer allowed.