Importing DEMs into SketchUp

Why on Earth did the option for importing DEMs disappear in SU 2022? This is one of the main reasons I use SketchUp. I will not have to downgrade back to 2021. What a disappointment!

Hmmm… It’s still available in SketchUp 2022 for me.
Screenshot - 6_7_2022 , 2_08_21 PM

The import list looks the same in SU2020. I didn’t open 2021 to check but I expect it’s the same there, too.

Had to check, yes I see it too, and AFAIK I haven’t installed any extensions that would add file formats to the list.

I know I haven’t.

Here’s a screenshot from my version of SU 2022- No DEM option on my Mac.

I also tried to import a DEM and the files were grayed out when inspecting the folder.

Perhaps @colin can chime in.

Here’s a screenshot from my version of SU 2022- No DEM option on my Mac.

DEMs grayed out when I tried to import them.

Windows or Mac?

I’m using Windows.

Do you have a M1 apple silicon Mac?
Other importers (.ifc) are (not yet) rewritten as well.
Try this/
Close and exit SketchUp
In Finder, select the SketchUp application and hit Cmd + i (info panel)

Check the ‘use Rosetta’ box

Start SketchUp.

I’m not using an M1 Mac and can see that .DEM is missing from the v2022 import list. I’ve fwd the request to look into it on our end and will let you know if/when I hear anything.

For me, any version of 2022 (I have a few of them) on my Intel Mac running Big Sur, show the DEM importer. On my M1 Max MacBook Pro running Ventura, I see the importer when running Rosetta, but I didn’t when running M1 native. I tried disabling all non-standard extensions, thinking that maybe one of those was blocking DEM, but it didn’t help.

I’m not sure why I see DEM in Ventura under Rosetta and yet not native, and Eric doesn’t see it when on an Intel Mac and Monterey.

SketchUp 22, Mac Big Sur, Intel chip. I do have the DEM import option.