Sketchup crashing when importing DEM data

import
dem

#1

I am attempting to import USGS DEM data into Sketchup, but am having Sketchup crash no matter how big the original .dem file is, or what settings I use for the DEM import options.

However, I was able to make this work ONCE, but I cannot for the life of me figure out what I did different (or if I even did do something different) to get it to import.

This is absolutely maddening. Any help is desperately welcomed!


Should i reply several unanswered old topics individually on same subject?
#2

What SketchUp version and what OS?
Also, do you have a sample DEM file to share that reproduce this?


#3

Windows 10, and Sketchup Pro 2016

Here are Dropbox links to two files. First, the DEM that I am able to import:

Valjean quad

Second, a DEM of a similar sized area that crashes Sketchup:

NH quad

Both files are around 10megs, fyi.


#4

OK - I think I have figured out the problem. Not sure why it’s a problem, but it works.

When exporting from Global Mapper I projected the DEM into UTM and then exported with sample spacing of 10 meters (i.e., approximately the resolution of a 1/3rd arc second DEM).

This ruled out crashing because the DEM file was too large, or anything to do with DEM import options (I was able to import 100,000 points to make a really nice model).

I hope this helps some frustrated soul down the road searching for a solution to this problem.


#5

Thank you for the report. I was able to reproduce it and I have logged an issue for this. (Internal tracking: SU-33377)

Apologies for the inconvenience and thank you for posting back with a workaround.

May I ask what the resolution of the original DEM was?


#6

Was there ever an answer to this issue. I am having the exact same issue and can’t resolve it.


#7

There hasn’t been any resolution to this issue yet. If you have a sample model I can add that to the issue as well.


#8

I am also seeing this issue. I am using

  • Sketchup 2017 Pro Trial
  • Windows 10 Home
  • Intel® HD Graphics

This is easily reproducible with standard USGS DEM data.

  1. Install GDAL (https://viewer.nationalmap.gov/tools/rasterconversion/gdal-installation-and-setup-guide.html)
  2. Download the data from the USGS
  • Navigate to https://viewer.nationalmap.gov/launch/
  • Select “Download GIS Data” link
  • Search for “Addess/Place” Marlborough Rd, Raleigh NC
  • Click Find Products
  • Download USGS NED n36w079 1/3 arc-second 2013 1 x 1 degree ArcGrid
  • Unzip n36w079.zip
  1. Convert the ArcGRID data to DEM format
  • gdal_translate -of USGSDEM n36w079\grdn36w079_13 n36w079\grdn36w079_13\grdn36w079_13.dem
  1. Verify that the dem file was created properly
  • gdalinfo n36w079\grdn36w079_13\grdn36w079_13.dem
  1. Import the dem file with SketchUp
  • Start SketchUp Make 2017 User, Pro Trial
  • File -> Import
  • Select DEM (*.dem, *.ddf) file type
  • Select grdn36w079_13.dem
  • Click Import

I have also tried reducing the output file size by adding the “-outsize 1024 1024” option when generating the DEM file, along with each of the following output types

  • -ot Byte
  • -ot Int16
  • -ot UInt16
  • -ot UInt32
  • -ot Int32
  • -ot Float32
  • -ot Float64

Sketchup crashes about 95% of the time. i am occasionally able to avoid a crash, in which case I get a " DEM Errors: File format not supported:" message.

I was considering a purchase of the latest Pro license but it seems that this feature has been broken for years and has yet to be fixed which makes me question the cost of the pro license.


#9

Hi SketchUp Community!
Are there made any progresses in order to import a *.dem into SketchUp?

My aim is to import an ASCII-File with more than 135.000 points. While searching a lot I came up with two possible ways.

First is to import a *.dem-File. This one crashes every time I want to import, see all this comments. Contrary to SketchUp 2018 ArcMap import the file without any problems. Second one is to convert the ascii-File to the Collada-Format *.dae for example with MeshLab or Blender. Therefore I did not make any result yet.

I prefer any hints in order to import XYZ from ASCII into SketchUp.

Thanks a lot!!
Simon


#10

I spun my wheels on this one for a while as well. It’s frustrating that such an old and easily reproducible feature remains unfixed.

In any event, I’m using the following workaround. It requires:

  • Sketchup Pro
  • gdal_translate and gdalinfo command line tools
  • ThomThom’s excellent Bitmap To Mash plugin.

I’m working with a 1m resolution USGS DEM file called USGS_NED_one_meter_x38y378_CA_LosAngeles_2016_IMG_2018.img, which I downloaded from https://viewer.nationalmap.gov/basic/. Since that’s quite a mouthful, let’s just call it NortheastLA.img.

Step 1. Figure out the subset of the image you need. The full thing is roughly 10,000 x 10,000 height measurements, which would result in 2 * 10000 * 10000 = 200M polygons – far too many.

Make a png file:

gdal_translate NortheastLA.img NortheastLA.png

Open it in your favorite image viewer and figure out the region that you’re interested in. Something around 200 x 200 is reasonable. The neighborhood I’m looking at has an upper-left corner at 8500, 6200, so I’ll use “-srcwin 8500 6200 200 200” in subsequent runs of gdal_translate to limit the output to that region.

Step 2. Determine the range of elevations in that region. I couldn’t get anything other than an 8-bit png to work in Sketchup. Since that does not afford much vertical resolution (8 bits = 256 possible height values), you want to use its entire dynamic range.

Create a GeoTIFF file of the target region. The default TIFF output uses floating-point elevations, so dynamic range is not a concern. Then run gdalinfo to find the range of elevations:

gdal_translate NortheastLA.img -srcwin 8500 6200 200 200 Neighborhood.tiff
gdalinfo -stats Neighborhood.tiff

The resulting stats give STATISTICS_MAXIMUM=185.28 and STATISTICS_MINIMUM=128.87, the maximum and minimum elevations of my neighborhood in meters.

Step 3. Create the final png file.

gdal_translate NortheastLA.img -srcwin 8500 6200 200 200 \
    -scale 128.87 185.28 Neighborhood.png

Step 4. Import Neighborhood.png into Sketchup. Set its size to match the data; in this case, 200 m x 200 m, or equivalently 7874.0" since I’m still using caveman units.

Step 5. Create the height map. Right click on the image, select “Mesh from Bitmap” (an option provided by ThomThom’s plugin), and set the Depth to be the height range of the file. Here, the height range is 185.28 m - 128.27 m = 2244.5".

That’s it. If anyone can figure out how to get floating-point inputs like GeoTIFF to work, that would save a step, but the above works well enough for me.