Importing CAD files to SketchUp Pro 2015


#1

Hi, I am having an issue importing both 2D and 3D CAD files into SketchUp Pro 2015. I have done this previously with no problem. The file imports but looks like a condensed line rather than a plan. I have had files from this surveyor before and they imported fine and he says he has sent it in the format he has previously used, a dxf file,so am I doing something wrong or not doing something I should be. All layers are turned on. Has anyone had a similar problem? I have followed the instructions regarding importing these files and can’t see that I have done anything wrong.


#2

If you could attach the cad file someone can check it for you, otherwise it is just guesswork.


#3

2D Garden file .dxf (1.4 MB)
Here’s the file


#4

I get this after hitting Zoom Extents. If you don’t get the same, perhaps you could share a screen shot?
garden.skp (269.6 KB)

Scale’s probably wrong but it can be fixed.


#5

This is anther odd one, if you import in inches you get that plan, but in meters you get this.


So try fiddling with the import settings until you get what you need.


#6

Thanks so much - I imported it in inches and now I can see it. Something so simple. Many thanks, I spent all afternoon yesterday trying to work out why I couldn’t see it.


#7

It is strange that it looks different when imported in different units. I wouldn’t have thought to try changing the units if I’d gotten a bad import the first time.


#8

The units used in the file must be Millimeters, otherwise it wouldn’t make sense, and it imports OK with Millimeters as the import unit. Do not use the “Preserve Drawing Origin” setting, as the lower left corner of the large rectangle lies more than 700 kilometers from the drawing origin.

When you try importing it using Meters the scale becomes astronomical. Especially the tree blocks are problematic. They are probably originally created for use with Meters, and they (probably the whole drawing) have been scaled 1000 times for the look. I do not wonder that the importer goes haywire (with distances like 700 000 kilometers, twice as far as the moon).

Anssi


#9

I couldn’t resist playing with the file, as it had those good old height survey points as text. I used my old AutoLisp tool in AutoCad to put in height lines, and then, in SketchUp, the Sandbox from Contours tool to put in a terrain surface.

Anssi
garden.skp (394.6 KB)


#10

Hi Ansii

That’s fantastic except that I have 2015 not 2016 so it won’t open in my version of SketchUp unless I upgrade. Very impressed with the quick response from you all on here. Many thanks


#11

Here’s my version in the 2015 format…garden.skp (394.5 KB)

Have fun!

Anssi


#12

Ansii, you are fabulous. Thank you so much. I hope you enjoyed your modelling. Many thanks for your help.


#13

Hello!

I am having the same problem with my dwg import. I’ve tried the suggested: both CAD file and import settings are on meters and I’ve tried every possible variation in the import settings.

This is my file: Line.dwg (80.7 KB)

And this is what comes up when I import:

I’ve done it before, several times, and it has done this before but I have been able to fix it through cleaning up, purging and auditing the CAD. This time absolutely nothing I’ve tried is working. Any suggestions would be really appreciated!

Thanks.


#14

Did you try hitting Zoom Extents after the import has finished? When I imported your file, I then had to hit Zoom Extents to see the edges that were created.


#15

I have, just tried again and I still just get the black line.


#16

Not sure where your issue is occurring but when I import the dwg it comes in fine.

Line.skp (148.1 KB)


#17

What are you trying to model? The file is set to use Meters as units, and the polyline in it is more than 300 kilometers wide and it is located about 550 000 kilometers from the origin. That would be further than the Moon. SketchUp won’t work well with that kind of distances.


#18

Importing in mm, the file comes in ok (after zoom extents) but is huge.
Importing in meters, as the source file the problem occurs.

Maybe it could be imported in mm and then scaled down…surely its not intentionally that big…


#19

Thank you everyone - I think it was a case of not being able to see what was in front of me because I’d been looking at it for so long. The scale of the CAD file had gone wrong somewhere and when it is the correct size - not to the moon and back(!) - it imported fine!