Importing Cad file but it goes straight to not responding

I am trying to upload a cad file to SketchUp. I have saved the plan in a new file and cleaned up some layers. It was a larger file so the amount of layers is extensive but i do not think that’s the problem. I click to download it even after I saved it to a lower version and i get this remark


when I press close it just goes straight to not responding.
Any ideas I am desperate here!!

Not responding means the computer is working on it and you may have to wait. Some imports can take a very long time.
The comment about some geometry being extremely far from model origin can also cause major issues. In the import options you have the choice not to preserve drawing origin.

what does that mean that the geometry is far from model origin? how can I fix that?

It generally means the cad file has geolocation info that is nowhere near Boulder Colorado, the default for a sketchup file, and so it tries to place the geometry thousands of miles/kilometres away.
In the Import Options do not tick Preserve Drawing Origin.

thanks for your quick respoonse!
I tried again and it did nnot say not responding this time it just did nothing after I tried to import it

Attach your .dwg/dxf here and I can check it.

autocad file for sketchup.dwg (2.8 MB)
I deleted a lot of the extra hatching and text but the file was huge before I just placed this one on its own could that be the problem?

It does import but it is problematic and creates quite a large file, 43mb .skp.
I would suggest the CAD file itself needs some attention before you import it. I can’t help you with that.
This is what imports for me.

1 Like

oh man thanks for trying!! ok any ideas how i can do that or who can help me with that?

There are CAD people that frequent the forum, but I’d guess most of them are asleep at the moment, you may just need to wait for someone with that experience to help.

In the dwg file you have a lot of x-refs. Depending on what information they contain and you need, either delete it or insert it in the dwg with the Bind command.

Capture-04

pag-05

Learn about Bind in X-ref - Solved: Re: Exporting DWG Files with Xref - Autodesk Community

Use WBLOCK command to export only what you want - WBLOCK

Without X-refs in SU


Very good advice and normally first thing to do when you want to import DWG files in SketchUp.

pag-05d

1 Like

One thing to note is that turning layers off or freezing them has no effect on the import into SketchUp. The DWG looks a mess. Are there several plans of approximately the same structure, some at a different scale?

thank you so much everyone! I think I got it. Its not perfect but it definitely works!