Importing CAD drawing into SketchUp 2017

dwg
cad
import
autocad
options

#1

Hi. I am having a new problem importing a CAD site plan into sketchup. I usually start a project by downloading an Ordnance Survey drawing in CAD format and then import it into Sketchup. Today when I tried to do that it was importing but I couldnt actually see the drawing. The face me figure which is on the axis when you start a new file disappeared as well. Its like the view has zoomed out to infinity and I cant scroll far enough back in to the screen to capture the drawing. I know the import has worked as the layers show up in the dialogue box. I today updated my Graphics card driver to the latest version and coincidentally had no issues using 2017 up until today.
Hope you can help


#2

You should check in the import options that you have set the correct import units and that the “Preserve drawing origin” box is NOT checked. The latter will send the DWG lines flying hundeds of kilometers away from the model origin, depending on where your site is in relation to the datum point of your Ordnance Survey system.

Import Options are hidden behind the Options button that is tucked on the Import File dialog box.

Anssi


#3

Thanks Anssi
I got to the bottom of it. As you said I hadn’t unchecked the preserve origin box and the OS cad drawing ended up miles away from the drawing origin and as a result the workspace started behaving very strangely as Sketchup struggled to cope with the large distances involved. Lesson learned
Cheers
Malcolm