Importing CAD .dwg files into SketchUp Make

Can I only import existing CAD .dwg files into SketchUp with a Pro license? I currently don’t see that file format as an option when under the Import command in SketchUp Make.

That is correct. Cad file import/export is a Pro feature.


SketchUp User Guide:

Depending on what you are using SU for, you may either pay for Pro, if it is a commercial use, or if it is for personal non-commercial use, try converting with the free Teigha File Converter to DXF, then use a plugin to import that.

There are at least half a dozen on the SketchUcation Plugin Store. See

Not all DWG entity types are supported, but it might be enough for you.

1 Like

Thank you for the helpful information everyone!

Another question. Is the option to use layers only available in the Pro version too?

No, it’s in Make as well, but the Layers window may not be visible by default. Add it to the default Tray (SU 2017 on Windows). Sorry, I use SU on Mac so can’t tell you exactly what steps to follow.

I see it now, but I did just go ahead and purchase a license to utilize the full 3D import features and Layout portion of the software.

However, apart from what I saw previously when I was using the 30 day trial of Pro, I had the option to check or uncheck a box to turn the visibility of the layers on and off. Now, all I see when I turn Layers on is a drop down with no option to uncheck a box to turn off a specific layers visibility.

The checkboxes are in the Layers Window, not the Layer Toolbar - yeah, that’s confusing.

I found it, thanks!

I’m getting an ‘Import Failed’ error when trying to import both a .dwg and .dxf file of my AutoCAD model. Any ideas what the issue might be?

What did you use to create your AutoCad model? If you were using AutoCad Architecture or other “vertical” AutoCad variant, you should use the “Export to AutoCad” function to generate standard 3D geometry out of the special objects like walls and doors. SketchUp cannot import these.
Another thing: Autodesk recently released version 2018. It has a new file format, and other applications cannot yet import that, so if you are using 2018, you should save your file to an older format before importing it into SketchUp.

Hey Anssi,

I actually did not create the models in question. They were sent to me as AutoCAD FBX files that I in turn imported and saved out as DWG. I’m running AutoCAD 2015.

open the DWG with the free ‘Teigha Viewer’ (SU is using the same library) and save down to a DWG v2000. If still failing try DWG v14 and as a last ressort DWG v12 cutting of custom entity types (ARX objects) but also loosing some properties/structures.

1 Like

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.