Importing a .DWG file to Sketchup 2018 on a Mac

import

#1

Hi
I’m an architect. I’ve been using Sketchup for six months and as it replaces 40 years at the drawing board I’m currently using 2D which suits my work requirements.
My colleague produces our surveys in Autocad but when I come to import them as .DWG to Sketchup the drawing appears on my screen but I cannot edit it except to add to it and measure it. I’ve tried double clicking, control click but nothing makes any difference.
If I try to delete anything of the original then the whole original drawing goes, leaving just my additions on the screen.
I can ‘trace’ over it as Sketchup picks up points to run to.
I’ve attached an imported file.
@endlessfixThe Hatt Plans Version 2.skp (2.7 MB)


#2

I am in your line of business and have been using SU for over a decade and have used it as my main software for about 5 years after an Autocad grounding.

There is nothing wrong with what your colleague has done. When SU imports a file it groups it. All you have to do is to open the group.


#3

I expect you need to open the component for editing first.

Inside that component you’ll find other components, for example:

Look at the Outliner and you’ll see there are a lot of components in the model. To make any changes to the geometry inside them you must open them for editing.

You should have a look at this page and the others associated with it.

https://help.sketchup.com/en/sketchup/starting-cad-file-sketchup


#4

This video shows one way of opening a group for editing.

The conversion process has brought in a lot of layers which you may or may not want to keep. In general, it is best to put the drawing in order before you start working on it in SU.


#5

Simon mentions the layers. You should go through and make sure all edges are on Layer 0 before you start adding to the complexity of the model. TIG made a plugin called Default Layer Geometry to put all geometry on Layer 0. Running it on your model will quickly fix the problem.
Screenshot%20-%2010_6_2018%20%2C%207_18_03%20AM


#6

Thank you so much.

I’ve not yet managed to register with Sketchucation but after a lot of trial and error I managed to explode the group.

Whether I can do it again is another matter, but I can finally work in a more collaborative way with my colleague.


#7

You didn’t necessarily have to explode it. You could have simply opened it and then edited it. You might well want to keep the original drawing in its own group and make another for alterations so that you have a before and after. However, both explode and edit are available from a right click. When you get used to it you will find that double clicking a group to open it is faster.


#8

Actually I think you’ve highlighted my problem.
I’m using an Apple Magic Mouse and right click (Control Click) does not offer open or explode.

In fact I’ve just tried to go through the import process again and I can’t do it now!


#9

Get yourself an inexpensive Logitech 3-button mouse. You can get a wireless one for less than $20 and it’ll make working in SketchUp much easier.


#10

Hey, good post, glad you got some insight on the problem, a double click on a group or component should also open it for editing without going through the right click context menus… As Dave said, a three button mouse with a scroll wheel button is a must for sketchup. After you get used to orbiting using the center button without having to change your tool you will wonder how you ever worked without it.


#11

That does and should perform a regular right click, and a contextual menu which has explode. Works only when you right click on the object in question. You only need a 3 button mouse if you want to orbit with the scroll wheel as a button. Otherwise it’s not necessary at all.

To “open” a group, without exploding it, you just double click on a group or component. After your edits you can click away from it and it closes back into a group or component.


#12

Many thanks. Yes I’ve been able to to it now using my Magic Mouse - a great relief as I really don’t like 3 button mice!


#13

Keep the Entity Info dialog open as you’re modeling.
It’s your guide to the entities you’re working with.

CAD files come into SketchUp as a Component.
A single click on the imported geometry and a glance at Entity Info reveals that information.

Investing an afternoon viewing this playlist will save you months of frustration.


Example:
SketchUp Training Series: Components


Accuracy in SketchUp is contingent upon user input.
• Inference Locking via the Arrow Keys and Shift
• Precise measurement via keyboard entry; preferably, one with numeric keypad.

There’s far more powerful magic in a seven-button programmable mouse mapped to the Arrow keys.


#14

I do all of my SketchUp controlling using my MacBook Pro’s built in Magic Trackpad. I can get contextual menus by either control-single click, or by clicking with two fingers. I think that should work on Magic Mouse as well.

For orbiting while using another tool I briefly press control and command, and then start to drag. It will orbit as I drag, and I can press the shift key if I want to pan instead. When I stop dragging it returns to the tool I was using.


#15

When I teach SU, I find mouse settings to be a common problem as they seem to get messed up on school computers for some unknown reason. I’ve ended up having to start each class by making everyone open the control panel and check the mouse settings before starting and creating a handout as a reminder. Mouse settings should look like this:


#16

Thanks again. When I said I was using a magic mouse I actually meant a Magic Trackpad.


#17

…but, despite teaching with a mouse as posted above, I don’t personally use one for my own work back in my office. I use a Wacom tablet in combination with the MBP’s track pad as @colin describes. The Wacom pen has buttons on it and I assign Control + Command to the lower button to orbit (middle button on the mouse), and two finger scrolling on the tackpad to get zooming (middle scroll wheel on the mouse).


#18

Here’s a bonus suggestion then, in Accessibility you can set the trackpad options to allow three fingers to act like a drag. That means you can move things around, or do the orbiting, without having to press the trackpad. It makes for a very pleasant way to orbit. Once you are orbiting you can even lift two fingers, to end up orbiting by gently stroking the trackpad with one finger.