How to import a .dwg file(PC) to Sketchup on a Mac without having Autocad

Hi. I’m new here. I’m just setting up with Sketchup on my Mac. I am doing a renovation complete with presentation drawings and construction drawings. I don’t have Autocad on my Mac but I will be using Autocad (PC) drawings as base drawings to construct my new renovation drawings on Sketchup (Plans, sections, elevations, details and 3D images). I will also be coordinating with engineers who use Autocad (PC).
My problem is trying to import the files to Sketchup. My partner first sent me .pdf files by Gmail which are static images that one cannot manipulate, so I asked him to send the drawings in .dwg format. My Mac will only open them in Adobe Illustrator so the files end up being in format and I cannot find a way to import them with the ‘import’ function in Sketchup. Does anyone have an idea on how to do it? Duh…I’m a beginner - it must show…

Can you not import the .dwg files sent directly to you? Don’t open them with AI first, just File>Import and navigate to the file. If your file is greyed out hit the Option button at the lower left of the popup window and set the file type to .dwg. You can also just grab the .dwg file off your desktop and drag and drop it into an open SketchUp modeling window to start the import.

Hi. Thanks for your response. What is weird is that I download the .dwg file, then when I try to save it from the download file onto my desktop by double clicking it to open it and save, it automatically opens it in Illustrator.

I’m trying again…

don’t double click the file. Is it in an email? Just drag it onto your desktop and let it go.

Oh, OK I’ll try that. Thanks

Double clicking a file will always try to open it, the system will pick whatever it thinks is the best application for that. In this case you do not want to open the file, just save it to a place on your hard drive. Then you can import it into SketchUp.

The problem is that I cannot manipulate a file in my download folder without opening it. It doesn’t drag from the download folder to the desktop. If I use file import from the Sketchup software and migrate to the download folder, all of the files in the download folder are greyed out. If I press options and choose .dwg file format, nothing happens because, since all of the files in the download folder are greyed out, the computer doesn’t identify any file in particular. I tried dragging the .dwg file, as you suggested, directly from the e-mail to the desktop, but it changes it into a weird format that is blank and unopenable, called .webloc. The loc part doesn’t sound promising

Trying clicking on the thing that you dragged from the email. If it is a web location file, clicking it may open Safari on a page where you can download the DWG.

OK Here it goes!

Thanks. It automatically uploads the original file from the e-mail into my download folder and returns me to step one. Grrrrr (insists on opening with Illustrator)

You’re right. It is a web location file; the location of my original e-mail!

There may be something wrong with the formatting of the original drawing. Yes it says .dwg, but maybe it’s zipped. I noticed that Illustrator opened several architectural drawings off one file and half of them were upside down. I’ll ask an architectural technician at my partner’s office tomorrow for help. Will get back to you and tell you wha the problem is (was, hopefully) fyi. Thanks so much for your patience!

Hey Colin
I just took a last try at it. I let the .dwg file download automatically to Illustrator, then, once it was downloaded, I pressed ‘export’ from Illustrator, chose the .dwg format and it did import to Sketchup! Success! (Now I will have to learn Sketchup, haha…)
Thanks and good night! :grinning:

Are you able to change the download location to the desktop? This is in the general preferences for Safari halfway down.

Never figured out how to avoid the downloaded file being automatically opened in Illustrator. As soon as I click the .dwg file in the download folder, it automatically opens in Illustrator. I figure there must be something in my preferences somewhere that makes Illustrator the default software

Hmm… When you say “the download folder” are you talking about the downloads folder on your hard drive? Does the file say .dwg there in your downloads folder? What is the download hosting service? Where are you trying to get the file from? can you try right clicking on the file and see if your browser has an option to download linked content.

But you should never be opening the file, no double click. Are you saying you are clicking the link online from the hosting service once and it is opening with illustrator?

Is this something you can make public by sharing the download link so I can have a crack. You can PM me(Click on my wrench icon to send me a personal message) the link of you like, I’m a trustworthy fellow.

Sometimes right-clicking or Ctrl-click can be your friend. You can Ctrl-click in MacOS on a file in the Finder and choose open with and even choose other if you don’t see what you want in the menu.

In the eMail itself, you can Ctrl-click on the attachment and choose save, and choose where it’s saved, not just a default download folder.

Ultimately you need to import a dwg into SketchUp, not Open it.

RTCool does mean Ctrl-click, not Command-click.

1 Like

Thanks, your right. My hand knows what to do, and my tired brain can’t communicate it right. :stuck_out_tongue_winking_eye: