Importing a dwg plan a box comes up saying "This does not appear to be a Sketch up Model"


#1

Hi - I am beginning to download DWG files from architects for my work but the files turn into Sketch up format and then a box comes up saying “This does not appear to be a Sketch up Model”.

All I am wanting is to save them in DWG format so I can print them and possibly import them later into a sketch up model.

Thanks for reading this!


#2

If a *.dwg is sent to you, then that is what you download into your PC/Mac, the *.dwg.
If you then import it into your running SketchUp Pro program, then it will be converted into SketchUp’s *.skp file format.
Your text is confusing about what you do exactly.


#3

do you have DWG file association set to SketchUp?
if so, that would cause the message…
SU cannot ‘open’ .dwg, only ‘import’ as Wo3dan describes…
john


#4

This is the confusing part of your posting. Files do not magically change to a different format, you or an application have to do something to make that happen. So what are you really doing? For example renaming the .dwg to .skp or as John suggests telling the OS that SketchUp can open a .dwg (which as he observes it cannot)? You must import a .dwg, not open it.


#5

Thanks John - appreciate your time on this.

I have been sent DWG files by e mail so assume I have to download them before I can print them or import them into a drawing I want to make in Sketch up 8.

I don’t know how to access the “DWG file association set to Sketch up” as you called it in order to change this setting.

Any ideas?


#6

@wrgardendesigns;

we all need a little more info…
System and Version
SU Pro or Free [as you mention v8]

If your dwg’s have the SU icon than that is ‘wrong’ file association, and you need to change it, otherwise, leave it alone…


#7

Hi John,

I have SU Pro 8 (installed in 2013) on an Intel Cor i3 - 2330m CPUe ( 2.20ghz ) system.

When I download the DWG file ( sent as DWG) it appears on the bottom bar with a SU icon. I can store it in a document file but on moving it into a SU page the box refusing it comes up with…“it does not appear to be a sketch up model”.

Not sure what to do to correct this process.

Thanks John - sorry to be slow replying - I am trying to run a landscape business! ( www.willridpath-gardendesign.co.uk)

kind regards


#8

Irrespective of what application is associated with a DWG file, you should not try to open it with SketchUp.
Also you should not try and move it into a SketchUp window [which is effectively the same thing]
What you do with any file types that are not a SketchUp native SKP is ‘import’ it - see the File menu and in the Import… dialog choose AutoCAD [DWG] file-format.
There’s an Options button on the right - use that to include what information you have available…
I would not keep the CAD drawing’s origin as it might be miles away from SketchUp’s.
Choose the units used in the DWG - in the UK it will probably be mm if it’s from an architect, or metres if it’s from a surveyor - check the size of something once it’s in SketchUp - you can then rescale or re-import if wrong…

To fix the file association - right-click the DWG file’s icon and use Open with…. option in the context-menu.
Choose a CAD app and tick the ‘always open with’ box.
If you don’t have suitable CAD app, then why not get a free program like AutoDesk’s DWG TrueView [Google and download/install it] - this allows you to view and manipulate DWG files… - and associate DWG files with that ?


#9

Hoooorah!

I can rest easy. Thanks so much.

I am pretty swift with pen and pencil and freehand graphics, but clunky with technology - so many thanks TIG.

Appreciated.