Importing CAD 3D models into SkethupPro


#1

I’ve downloaded the free trial version of Pro in order to test out how well I can use it with existing CAD 3D files. I found that I can import the files I have, however, each file is missing most of the essential pieces. In one file, the structure imported but an essential component (a slide) was missing. Any advice?


#2

What kind of files? Have you experimented with the options settings in the import dialog?


#3

There is a report dialog window that usually appears after the import is finished processing. It would be good to see the results of the report in order to determine what was ignored and what was processed.

Are any of the items that are missing AEC objects?


#4

The files are CAD 3D- .dwg files. I have played around with the import options to no avail.


#5

Chris, I’ll check this out and report back…


#6

I don’t know about CAD 3D- specifically, but .dwg files as a whole are famous for having the coordinate origin placed so far from the geometry that there are issues in SketchUp. There can also be scaling issues if you don’t set the units to match the file prior to import.


#7

Chris, I looked up AEC objects per you r comment and performed the EXPORTTOAUTOCAD, and AECTOACAD commands according to a CAD tutorial I found. This didn’t change a thing when I imported the file to sketchup.

Here is the dialoge box that SU presents upon importing:

Lacy-


#8

any chance you can upload one of you CAD files so I can have a look?


#9

The mention of “zombies” and “empty blocks” etc. in the list of entities ignored suggests to me that there are proprietary objects present that were created in an application that you don’t have. The EXPORTTOAUTOCAD, and AECTOACAD commands only convert those objects that are from the AEC application that you have, not those from all “vertical” AutoCad additions. Another thing might be that the missing component might be using a type of geometry (like NURBS-based surfaces) that don’t translate into SketchUp. In the latter case you could try to convert it into polyfaces within AutoCad.

Anssi


#10

I recently ran into a similar problem which led me to this thread. For what it is worth, I was successfully able to use the -EXPORTTOAUTOCAD command. I had to use the dash for the command to successfully work.

@lacy if you haven’t solved the issue I could give it a try if you want to PM me a file. Since it’s been a month, I am guessing the issue may have been resolved.


#11

AutoCad Architecture? (Judging from your screenshots)
The command is also available in the UI but old-timers like me often use the command-line versions.
Note that the result depends on what is on your AutoCad screen when exporting: A plan view produces a 2D plan drawing, and a 3D view exports a 3D model.

Anssi


#12

I’m using the Mac AutoCAD 2014 version. You are right @Anssi on the results being different. Here is what I am seeing when trying to take a .dwg with AEC Wall entities from AutoCAD to SketchUp.

  1. No export (just trying to import the .dwg) = AEC entities are ignored.
  2. -EXPORTTOAUTOCAD in plan view = AEC entities are converted to 2D geometries.
  3. -EXPORTTOAUTOCAD in 3D view = AEC entities are converted to 3D geometries.

In my situation, I just wanted to get a base to trace on top of, so option 2 worked best for me.