Imported rectangles are not surfaces

I’ve imported an AutoCAD drawing sent to me by others. I have two problems with the imported file;-
1 - a number of the lines don’t meet up at corners. When you zoom in, they don’t touch, so I have to extend the lines so they meet and form a surface that SketchUp will recognise. Is there a way of adjusting the import tolerance, so that SU will ‘find’ lines that are missing by a small amount, and join them automatically?
2 - Some rectangles do join at all four corners but still don’t form a surface that can be extruded, or will hold a texture. If I draw a line from one corner to the opposite, one of the two triangles is a surface, but halving the other triangle still forms a smaller and smaller ‘hole’ (does that make sense to anyone?!). It is behaving as if the four corners are not in the same plane, and even drawing a new rectangle over the top which overlaps the corners does not resolve it to a surface. Is there a fix?
Thanks in advance.

You could use thomthom: Edge Tools

1 Like

Hi. Looks like a handy tool, but the disadvantage to me is that before I can get it to close the gaps, I have to find them all!! and there seem to be loads.
I’ve used CAD programs before (eg Microstation) where there was an import tolerance setting that would detect lines very close together (like 0.1mm apart) and join them on import.
I suppose that’s what I’m hoping to find

SketchUp’s internal point tolerance is 0.001"
There’s no import tolerance setting to accommodate poorly drawn CAD linework.


Here’s a screen grab showing the problem described in point 2 above.
Notice that at the 24 second mark, the rectangle does fill, but so does another rectangle which is part of the window plan…???
At the 50 second mark, I try to divide that rectangle into triangular surfaces, but it only ever accepts one of the two desired surfaces…

Might you share the CAD file instead of pictures?

1 Like

Do you know you can select all the geometry then ask Edge tools to close the gaps and set the tolerance as small as you like.

SketchUp doesn’t automatically create faces in imported 2D CAD linework.
And creating faces in a 2D CAD import can be problematic due to minor errors in the CAD linework.

While actively modeling, SketchUp automatically creates a Face when Edges meet certain conditions.
When a Face fails to form it’s because one or more of the conditions haven’t been met.

Face Criteria
• The Edges must form a closed loop .
• All the Edges must be coplanar .
• No stray Edges, coplanar with the closed loop, project inside the loop.
• The Edges are not too short*, say <.002" in length.
• *Certain operations may cause even larger faces to fail.

Heal a missing Face by tracing one of the bounding Edges, endpoint-to-endpoint with the Line tool.

Handy plugins for CAD import cleanup.

  1. Repair gaps using Edge Tools²
  2. Make new faces using Eneroth Face Creator
  3. Cleanup many remaining issues using ThomThom’s CleanUp³

Edge Tools² by ThomThom²

Edge Tools requires a supporting plugin, TT_Lib²

Once the edges are repaired, try running Face Creator

Eneroth Face Creator

Careful use of ThomThom’s CleanUp³ can help as well.
It requires the same TT_Lib² supporting plugin.

CleanUp³ by ThomThom

It’s easy to learn if the edges are coplanar or not.
Hover the Tape Measure tool over the endpoints.
Notice it displays the x-y-z coordinates.

This is a small model.
It shouldn’t take much time to make it functional.
But in order to do so, you need to turn off the eye candy and zoom in so you can see the edges you’re working with. Profiles and Shadows … Off

test.skp (302.3 KB)

1 Like

This was cleaned up with Edge tools. and a bit of manual finding holes.
Took a few minutes. But I exploded the components rather than did them individually.
testBox.skp (333.5 KB)

1 Like

I found no gaps in the model you shared.
I did find edges in different contexts that preclude creating a closed loop of edges.
The largest issue was tiny lonely edges created by overlaps.

I found all edges to be coplanar.

No plugins required.
If you want to model walls, then sift out the geometry of the walls from all the other clutter.
With that, turning on Endpoints makes finding the errors easier.

Test_001.skp (310.1 KB)

1 Like

Understood, but part of my question (actually the important part, to me) is why I’m finding it so difficult to make coplanar lines into a surface? Everything is Level 0.

Again, @paulr share the model file instead of pictures

That animation shows a different model than the one you shared before. We can’t say anything definitive about this one until you share it. Before that we’re just guessing.

1 Like

It was the same imported .dwg file. The first post was of the plan only, which had been stripped of elevations to reduce file size. The second video was of elevations from the same model, this time stripped of the plan.
What I hadn’t realised was that searching for stray edges is a waste of time in anything but orthogonal views, as you can’t zoom in enough in perspective without clipping the detail.