Important Update on a few Potential SketchUp 2017 issues on Windows


I did try updating the drivers. I tried through Lenovo, Intel (there’s even a program that checks for you), but nothing seems to work.

I went to the Intel Site looking for the latest 4400 Drivers and found []

Currently, the page is down.

So I downloaded the the latter []. I tried installing the program but I get the following response.intel3

I also tried using version [] and received the following popup.intel4

I don’t to sit there and keep trying every single driver update. There has to be a better or more efficient method…


sure, use the Lenovo System Update tool for downloading/installing the most recent drivers/updates automagically.


Downloaded and installed the tool. Made a few updates. I restarted for good measures and attempted to open the program. I chose ft/in templated and clicked start. This time, the program managed to open a plan template with the man standing but the system crashes/closes after half a second.

Still a fail. Crash Report #415225

Updated the following items:


I checked the crash - ig75icd64 indicates an issue with the Intel Video card/driver.


Looking at your updates list I would guess that a cold boot might be in order.


Is there a fix?


which ones? Try uninstalling all 2015 versions of the Visual Redistributables, then try installing SketchUp (Run As Administrator) when prompted choose ‘repair’


Because it is related to the card and driver, you will need to update the video card driver or video card to be able to run SketchUp 2017.


Sorry, that did not work.
Crash Report #415502


Is it possible to be more specific? I have tried Intel site. I tried using Lenovo site. Getting the blank template screen for half a second is the closest I got with the latest Lenovo updates.


simply use a notebook adhering to the SketchUp Hardware and Software Requirements, preferrably with a dedicated nVidia GeForce GT(X) graphics card integrated.


As @ty_s wrote:

Since updating the driver wasn’t effective, the next thing to do is update the card. Unfortunately for many notebook computers, that means replacing the entire computer.


Shouldn’t have to go through this trouble just to use your software.


He initially indicated using the Make (free) version, thus technically not “his” software.

Also, most (if not all) software have minimum requirements, these need to be met in order to utilize the software.


That’s not a real option for me at the moment.


Am I reading something incorrectly? I’m pretty sure my laptop meets the minimum both HW and SW.


So far, none of the Intel 4400 drivers on the Intel site work for my laptop either because it’s “not validated”, “not support”, or “not meet minimum…”. I even tried 32-bit versions just for kicks.drivers

SketchUp Check said I meet all the requirements. sketchcheck

There’s something going on but I don’t know where to troubleshoot anymore.


Evidently not. Your problems stem from your graphics drivers. If there isn’t a suitable driver for the card, then your computer does not meet the requirements.


After clicking on the Start using SketchUp is when all plugins start up. I wonder if you have a plugin that is causing the crash? Also might be worth installing the 2016 version, so you can at least do some modeling!


claiming to support OpenGL v3.0 is not sufficient, a complete and mature support of OGL v3.0 is required.

but anyhow, do you want to discuss the issue endlessly or get things working?