Important Update on a few Potential SketchUp 2017 issues on Windows


@DaveR Im not sure its Vray, yet. By the way wats your fav renderer?


Most of the Bug Splats have indicated that vRay was the cause.

“My tire keeps going flat.”

“Here’s your problem. There’s a hole in the tire.”

“I’m not sure it’s the hole, yet.”

I use Kerkythea, the forerunner of Thea.


Hi all, I following this discussion because I probably have the same issue. After installing Sketchup I have a lot of freezes and crashes, mostly seconds after orbiting/drawing. I’ts totally frozen and I have to force the program to end. It happens with other programs too which uses some more computer capacity like Photoshop or games.

After trying almost everything including a fresh Windows 10 install, I found where my problem happens. With installing Sketchup, Visual C++ Redistributable for Visual Studio 2015 14.0.24215.1 gets installed too. This is where all my problems start. After simply deleting the VC 2015, all my problems are gone. Because it happens with other programs too, my guess is that it is not pure Sketchup related. So I continue follow this topic, hoping I can find a clue here.


Did this issue start recently and was there Windows update installed recently on this machine? If either is yes, then most probably, the Windows update is causing this issue, so please check the following:

  1. The update may also have caused the Intel graphics card drivers to be changed, in which case, please update the Intel graphics card drivers from as shown in Updating Intel Graphics Card drivers .

2)The update may have changed the SketchUp graphics card preference to Intel (from the dedicated one), in which case, please change the settings to use the NVIDIA or AMD graphics card.

  1. Revert the machine to the previous status or uninstall the KB’s listed in Selection Tool process is slow, unbearably slow

Let us know what worked.


Hi there, I have an Intel HD 4000 graphics card, windows 10 64 bit operation system. I am having the same problem with the selection tool freezing. I can orbit around fine, but when I go to select things it freezes. I only installed Windows 10 operating system back in May, I had no problems until about a month ago when I had several Windows updates: Following are a list of all of the updates that have happened on Windows 10 to date:
I took your advice and went to the Intel website and got their latest graphics driver, however windows didn’t install it and said that I have the best graphics driver for the card. I only have the Intel HD 4000 graphics card, so couldn’t change graphics cards. As for uninstalling previous KB versions, they are all old updates - I installed Windows 10 about 3 months after those updates so cannot find them on my system. I have listed the updates on my system above.

My selection tool was working fine before, so I don’t think it is my graphic cards capabilities. Please let me know what I should do to get the selection tool running again.



Have you checked the widows update in the control panel and see if there are restore points for those KB. Some cannot to be removed once you install them however.
You cannot count on the relative age as an indicator its chage is not causing a problem. I ran into a cast where a 3 year old …dll and a recent update of a app caused a problem, depends on the code.
Checking for recent updates but do not do auto install before reading what is done.


If suggestions below do not help it may be worth a shot to try MS tech net and see if you can get some help via the Windows SytemInternal folks. They have many apps that allows them to check what is going on. Those apps are designed so they do not affect the operation of the machine and they can do a deep dive into what is causing the issue.
I do not imply you use the apps., learning curve too high. Thinking they may be able to check remotely or ???
Just some thoughts


Hi ty_s,

Thank you for your suggestions. After 1,5 months my problem is solved. It seems that one memorycard never worked. Removing the broken card solved my problems.

Thanks for your help!


Hi Gopalius- I’ve been having similar problems as you and a lot of other posters here. I got things running ok after working with tech support from Dell. My system had an Intel 4000 graphics card, and I also had trouble finding updated drivers, Intel always telling me my drivers were up to date. I don’t know exactly how we got our system running, as the tech and I did a bunch of tidying up on my system. But one thing I did notice, and I think may have done the trick. Went to update manager and found the list of all recent updates-there’s lots of them as you probably notice microsoft is updating way more often than I’d like. It did, however, indicate, that some of those updated were never really installed properly. We re-installed those updates, and maybe that’s what got me up and running. Good luck!


I’m also facing many issues in different periods where Sketchup runs out of memory, crashes, and so on. I don’t know what to do as I already follow all the instructions provided here.

Does anyone have or found a permanent solution?


Was about to write and tell you that I had permanently made the fix, but lo and behold, just opened SU and the problem is back!!!If I refix, will let you know.


It seems no one can tell… keep the good faith and desinstall everything. Than after you have a house full of nothing,they tell you u must live and enjoy, living like that. And crashes keep going on. It must be another thing… than you desinstall… mouse,plugins and visualbasic and windows updates and drivers updates…nothing helps. Try to do some very small models. It seems to work. When passing by 80mb, forget…


If you start task manager and then resource monitor you will see there is a multitude of things going on under the hood that may surprise you so, finding the real problem can take many trails or you can enlist the appropriate help. I suggests strongly you try the System internals I suggested above . What do you have to loose at this point?
FYI: Some of the updates MS install on your machine they specifically state they cannot be removed!


If a single person was facing the issue I’d be “that’s fine, it might be something wrong on his environment” but the real deal here is that many of us are complaining about the same thing over and over.

Is there anything down the road to fix such issues? Should we raise a request and ask for appropriate escalation until reach some Sketchup software engineer?

It is frustrating to keep blocked for those out of memory, crash and no solution so far!


Are you using Vray @vdeschamps?

I’m asking as @mr_robinson seems to have some conflict which regards vray. However I have a model that I’ve bee working for long, which has passed 80Mb (it isn’t much bigger actually just 85Mb) and it doesn’t crash a single time.

However I did have a plugin installed, that crashed it every time I moved and autosave kicked in at the same time.

I eventually nailed down the problem to that plugin and since then I have had 1 bugsplat a month if that much.

If you follow the steps mentioned above and nail down the culprit (maybe a plugin?), you probably can solve the issue while others can’t or don’t want to.


@JQL yes, I am and I was informed to test it without. I’m going to test today and update by the end of it.


Hi, everyone.

I’ve been trying to get SketchUp Maker to start up on my laptop but the program keeps crashing.

SketchUp 2017 Checkup says I pass.sketchcheck

I can only make it to the prompt window screen.

When I click on “Start…” (SketchUpMake-en-x64), the system crashes and I end up in bugsplat window.

I’ve tried Windows Update, Lenovo drivers update, Intel Graphics check update, uninstall/reinstall SketchUp, and delete/install some of the C++ Runtime libraries. Nothing seems to work.

I’m at a total lost. Can someone hold my hand and figure this out?

Thanks in advance.


The first question to you is, did you install SketchUp correctly? That is, did you right click on the installer file and choose Run as administrator?


I looked up the crash. It looks like your Intel® HD Graphics 4400 is causing the crash. You will need to update the driver through Intel to get that up and running. Some Windows updates will revert your video card driver so you may need to re-update them.


I think I did. I am the only account holder of the laptop. I also performed your suggestion with the same results.