Important Update on a few Potential SketchUp 2017 issues on Windows


@sketch3d_de, I apologize if my impression is to just complain. I have been taking people’s advice in this community and responding back with results. If you read some of my responses, I have made progress… I was able to get the template window to open up before it crashed agian. I’m not ready to give on the program just yet. I remember using this program when I first got this laptop. Between the years of update and changes, something must have affected it. I’m not an expert with video cards and drivers so that’s why I’m here get a better insight or step by step approach to troubleshoot this issue.


One key thing is that with sketchUp 2017, a graphics card with suitable drivers is a requirement. In the past it was optional and you could turn off Hardware Acceleration to make the CPU do the work. That’s no longer an option with SU2017. If you are going to run it, you need to do something about the graphics card and its drivers. The crashes you get have already been identified as being caused by the GPU and/or its drivers. The way is clearly spelled out for you. You just need to figure out how you’re going to get there.


Are you able to run SU16 on your machine? It’s still available from SU and a valid option to use with older hardware.


I tried version 2016 (both versions) and it says my trial has expired.
I tried version 2015 (both versions) and it says the system errored out.

Thanks for the advice though.


I suppose it is. Thanks for help.


I’m at the point where I have accepted the fact I won’t be playing with SketchUp anytime soon with this laptop. Out of curiosity, is there is a program where I can test what my graphics card can support? My Graphics Support CP says it is currently running OGL v4.3. Can you please explain what I am looking at?


SU v2017 intoduced an enhanced system requirement concerning the OpenGL version required as well as the supported range of OGL functions delivered by the graphics card driver. Additionally, the ability to disable the OpenGL hardware acceleration (= GPU) in the preferences or using a 32-bit version for being more compatible with graphics card driver versions (regularly req. for AMD Radeons) was removed.



I solved this problem by disabling the “Application Optimal Mode” (Intel HD Graphics Control Panel > 3D). It needed restart of the computer but after then I can use SU2017 without any freezing problem of select tool. In SU2016 was a option in preferences to disable hardware acceleration but SU2017 doesn’t have similar function.

I hope that’ll help you.

My PC:
Dell Latitude e6430
i5-3340M, 8GB RAM
Intel graphic HD 4000, driver


Where did you find that mode setting?


Hello catamountain, thank you for tip I didn’t mention so important thing. The option is in menu of Intel HD Graphics Control Panel > 3D, the Application Optimal Mode is on top.



Thank you so much for this link. I installed and attempted to open the program but it also crashed.
Crash Report #531923


This crash also appears to be related to your video card/driver.

For SketchUp Pro 2016 (does not apply to SketchUp Pro 2017):
Please try disabling Hardware Acceleration. I would also recommend that you make sure your drivers are up to date for your video card (and if you are still having this issue, try a driver that is 6 months old) to see if that helps.

To turn the Hardware Acceleration option off:

In SketchUp (this effects LayOut also):

  1. Open the “Window” menu. (Open the “SketchUp” menu.)
  2. Click “Preferences”.
  3. In the left pane, click “OpenGL”.
    4A. In the right pane, clear the “Use Hardware Acceleration” check box.
    4B. In the right pane, clear the “Use Fast Feedback” check box.

If you are unable to open SketchUp, please try the steps found at this forum post: Can't run SU in Windows 10

Running the registry editor contained there should turn off Hardware Acceleration within the SketchUp registry so you can start it.


you can disable the hardware acceleration setting (= OpenGL) from outside SketchUp by using the free ‘OpenGL Config’ tool.

Just download to e.g. desktop and run, no installation required.


The program says I don’t have Sketchup installed. Am I missing something?config


I cannot open the program. Will this also work for Windows 7?


than something with the SU settings in the Windows registry is maybe havoc, use the REG files already mentioned above instead.


That worked!

Should I upgrade to 2017 as suggested or just stick with 2016 that works?


Each version of SU is a unique installation which co-exists with other installed versions of SU. So if you want to try upgrading to a later version of SU, do not unistall SU16 just yet - it works on your computer.

As mentioned above, SU17 requires hardware acceleration - a graphic card/chipset with 100% OpenGL compliant driver is required. In SU, you can check how much SU likes your graphics and driver by going to the Window menu > Preferences > OpenGL. Are you able to run SU now with the hardware acceleration option enabled? If you can only run SU16 without that option enabled (that means the CPU is doing all the rendering) then it’s unlikely you can run SU17 on the configuration of your current computer. As mentioned, you need a different graphic driver. Usually that means the latest driver, but sometimes a slightly older driver may work better.