Important Update on a few Potential SketchUp 2017 issues on Windows


the fall-back to version 2016 was recommended because of the faulty itnel HD graphics driver, trying to use version 2017 again doesn’t make much sense than (see above).


The answer is a NO. The program crashed as soon as I restarted and chose a template. Thank you for helping.


@sketch3d_de, thank you for being patient with me. I’ll be playing with 2016 until I upgrade my system then.


So the takeaway here (after reading almost this entire thread) is to avoid SketchUp 2017 at all costs. My question is: How and why does this level of failure happen? Sorry for the non-positive feedback, but the lost productivity from users whose livelihood depends on this product must be significant. It seems incredible to me that this version was never pulled.


You should count the users without problems too to get a fair comparison…


True, but it’s not the sort of ringing endorsement that one would expect or want.

In any event, I had hoped to finally upgrade to the Pro version. I don’t use SketchUp professionally and have gotten by just fine with the free version, but I wanted to unlock the features that come with the paid version. I’ll continue to wait.

It’s a risk/benefit calculation. The benefits of upgrading to the current version – when SU 2016 works perfectly well – are not worth the potential headaches and downtime just to Beta test a product that you’d have to pay a good chunk of money to get. Human beings are odd that way, I guess.


hi everyone,

I’m new to sketchup + vray and in this group. I have just been using Sktchup pro 2017 + Vray 3.0 on MAC since September 2017.

Mac details:
OS Sierra version 10.12.6
Memory: 8GB 1867 MHz DDR3
Graphics: Intel Iris Pro Graphics 6200 1536 MB

I have encountered a lot of Bugsplat crashes. I have adjusted autosave to 3min.

here is one screenshot of the details.

I always send report.

At first i thought it was due to the size of file. But even when my file is new, at 15mb it still crashes.

I’m not so well versed with computer talk. Would appreciate if anyone could shed some light on this issue.

Thanks so much in advance.


I kept getting prompted to download the new version of SU but when I did it and installed it, it seems to be the same 2016 version of SU Pro 2017 I already had, version 17.3.116. Is this the latest 64-bit version?


SU v2017 is 64-bit only:

Windows : 17.2.2555 (15.02.2017)
macOS : 17.3.116 (21.09.2017)


How do you open your SKP files? Do you double click the SKP or do you open SU and then navigate and open the SKP?

If you double click the SKP file it opens in the last version it was saved in, which then could be your older version which still resides on your machine.


Except that only one revision of a version can be installed so double clicking on a SketchUp 2017 file will open it in the currently installed revision of SketchUp 2017.


Hmmm, quite right. :flushed:


Thanks. It was confusing to see the 2016 year in the copyright notice but I have the same version number as you, so I guess it is the latest version.


Update : Microsoft .NET Framework 4.7.1 (Offlineinstaller) for Windows 7/8/10


Earlier this eve I tried to run my up-to-date version of SketchUp Make 2017 on the Windows partition of my Mac (using Bootcamp), and found that it’s still running extremely slowly. Example: the Select tool takes almost 10 seconds to recognize my selection. I then ran the SketchUp 2017 Checkup, and the result it states that my computer met all the minimum reqs to run SketchUp. Obviously, there is something not up to par on my Win 10 partition, but what it is, I just don’t know.

I also have SketchUp Make 2017 on my Mac’s OS X, and it runs find on the OS X. I would prefer to run SKM '17 on the Win OS because I need access to other programs I have on Win 10.

I’ve read some comments on other threads on something like, "Did you install it properly as “administrator.” What is this all about? Help, please.


Just another cry for help! My Sketchup 2017 worked flawlessly until last week, after the Windows 10 Version 1703 for x64-based systems (KB4049011) was installed. Now I have the 7-second freeze every time I use the select tool, which also means that double- and triple-clicking obviously doesn’t work. Seems the problem reported in earlier posts can occur fresh and anew. What should I do? My graphics card driver is updated to the latest version and has not changed recently.

PS: The latest Windows update seems to have solved the problem. Really weird. Makes you wonder what is taking place under the hood… DS


Really frustrated here. I would love to use Sketchup Make 2017. I have a 6 month old Microsoft Surface. Sketchup crashes on start up every time. I have updated my computer and graphics driver, downloaded Sketchup 2015. Still no joy.

Will I be able to get Sketchup running on my machine?


Your profile indicates you have an “Intel HD Graphics 602” but according to Microsoft, it’s probably an Intel® HD Graphics 620. You might want to read this information.

What version of OpenGL does it support? Have you tried updating the drivers?


Dave, Thanks for the quick reply.

You’re correct, the Device Manager indicates I have the Intel HD Graphics 620, not the 602 as my fat, carpenter hands, typed.

No earthly idea what version of OpenGL it supports, nor how to find out. Yes, I’ve tried updating the drivers.


If updating the drivers doesn’t help, maybe rolling back to an earlier version will help. Intel Graphics drivers are notorious for less than adequate OpenGL support.