Important Update on a few Potential SketchUp 2017 issues on Windows


#86

I disable almost everything, includind 3dconnection mouse. I get this. Two times a day.


#87

Scroll up to the first post in this thread. You will see this:

By reinstalling/repairing SU, the installer will install the required version of VC++. Back in December, MS released a bad version of VC++.

After uninstalling the VC++, you should just need to r-click on the SU17 installer file > choose Run as administrator. This will bring up an option to repair SU because SU is still installed. Choose that.

It’s also possible to directly go to MS update site and download and install the required VC++ too. Do that if the SU installer fails to retrieve VC++.


#88

Thanks that will be my 8th reinstall last month.
You are all very kind but this is not understandable. I keep waiting for responses that never come. Desintalled almost everything. Everything have a issue, drivers from Nvidea, drivers from 3Dconnexion, Vray 3.40, plugins, devellopers keep develloping fast to achieve comercial timing, quality control is made on the run, with clients. Pro clientes don´t want to “try to…”, “pearhaps if”.
We pay for a product to run with efficience.

I´m on a delay with my clientes because of “who knows what”.
If I know I´ wouldd´t never make na investment in this Sketchup+Vray solution.
Sorry I cant have no mores excuses with my business and clientes, they don´t desearve.


#89

But when you reinstalled SU, did first uninstall any versions of VC++? Uninstalling SU did affect VC++.

After disabling all the plugins, you finally got an error message regarding VC++.

A required component that comes from Microsoft seems to be the problem. There are known issues with some versions of VC++. Without FIRST uninstalling the bad VC++ through Add/remove in Windows, just reinstalling SU will not fix the crash problems you are experiencing - at least ones which are related to VC++.

After UNINSTALLING VC++, then the SU installer will ping Microsoft to get a better version of VC++ to install on your computer.


#90

Hy,
I´ve uninstall Microsoft Visual Studio C++ 2015, as you kindly proposed me.
Just that (at least the 2 named that way). But I have lots of Microsoft Visual C++ installed in the machine dont know the reason. 2008,2010,2012,2013 and today only one file 2015 x64 v.14.0.24215

Thanks for your help @catamountain


#91

You have a lot of VC++ versions installed because many of your programs also required specific versions of VC++ when they were installed. All those versions co-exist. You need a new version of VC++ 2015 64-bit . To keep things simple - to get the right one - let the SU installer do the work.

Don’t uninstall SU. Just go to the installer file you downloaded from the SU website. R-click on the installer > Run as administrator. Because the program is still installed, you should get a window with an option to repair SU. Choose that. If all goes well, the installer will recognize your computer is missing VC++. It will ping Microsoft and install a fresh version for you.


#92

see point 5.) of first post.


#93

Hy i did reinstall VC++, desintalled 3d connexion (by suggestion of Vray) , and you know what?
Its equal. Crash after crash. Sorry :wink:


#94

Did you submit those bugsplat reports too?


#95

Whenever its generated a bugsplat I send it, because I´m hoping someone can see them. Thats the case attached 3 files dont know watts in it, but I´ve no news from support, except from here, who are lots of people interested to help, like you @catamoutain , @mchandler.


#96

Nothing like the first crash in the morning.
This is always happening when editing a group, scaling textures in RT mode (Vray) rotating angle or scale texture, Vray strugles, Sketchup freezes, screen gets white than crash appears. Send Bugsplat to complete understand.


#97

New error with the new C++


#98

Are you using V-ray when all these bugsplats and C++ error occur? By any chance do they occur when SU is auto-saving? If so, some people disable autosave and develop a habit of frequently saving during the modeling session.

Another ‘quick’ test - and one you haven’t tried - is to check if another program is interfering with SU. This rarely happens, but it has happened to at least 2 people I’ve encountered. To do that, run SU in a clean boot state. Essential Microsoft stuff loads as well as your graphic driver, but nonessential programs are not loaded. Use SU as normal to check if any bugsplats or other errors occurs.

I use a 3Dconnexion navigator, FredoScale and 50 other extensions without any problems on my machine. Although I do not have V-ray.


#99

I have tried everything mentioned and my SU17 still crashes consistently while working.
My SU 14 never had this problem.
My graphics card is GForce GT 710
Who can help me with this?? Im loosing money with all these crashes.


#100

I have also tried everything and I use Sketchup for work. Everytime I try to open the either of the two versions of Sketchup that are on this computer; (we have Sketchup 2015 Pro and Sketchup 2017 make) it crashes. It is only on my computer, and I have uninstalled and reinstalled three times. For some reason, it works for a day and then proceeds to produce a bugsplat after upon opening. It is only my computer that does this. Our tech guy has tried several things, and he doesn’t know either


#101

@Billy, you list an Intel GMA 3100 as your graphics card. Are you using a laptop? In SU, go to Window > Preferences > OpenGL. Click on the Details button. What does SU say you are using?

@Trent.S, your profile is missing some important info - what is your OS and graphics card? Have you updated the driver for the graphics card? Have you installed extensions for SU?

For both of you, are you submitting your bugsplat crashes with identifying contact info?


#102

+1 to Catamountian’s comment
If you are getting a bugsplat, please enter your email address into the bugsplat form and submit it for analysis. Please also contact support here and let them know that SketchUp crashed, what OS you are on, what version of SketchUp you are using, and the email you used in the Bugsplat form. We can then take a look at the crash and let you know why it is crashing.

To that effect, the top crashes we have are because of plugins or video card/driver issues.

  1. Please try disabling plugins to see if the issue goes away (and then add them back slowly to see when it comes back) http://help.sketchup.com/en/article/1700320
  2. Please also update your video card drivers.

#103

Yes, I have been submitting the crashes when they occur. As far what kind of graphic card I have, my computer says it is AMD Radeon Graphics Processor, made by Advanced Micro Devices, Inc. The OS is Windows 10.


#104

@Trent.S, you have an integrated graphics processor not a discrete graphics card? Without more specific information about your graphics it’s hard to judge if your problem is graphics driver related. Your GPU may support Win10, but there’s more to do see if it would run SU. Update your graphics driver - from the AMD website or the computer manufacturer. Run SU Checkup. What does that app say?


#105

Thank you for your help. I installed the Checkup and ran it, but it says that the computer has met all the minimum requirements for Sketchup 2017. I’m not excavate sure what you mean about the graphics card and processor. While proficient at computer programs, I don’t actually know that much about the machines themselves. Here is a screen shot that may help. Thanks again for all of the help.